0

I have a pi 3, but my metal case is blocking the wifi signal. I bought a wifi dongle, which I'm not sure is compatible.

I'm using Recalbox, which I think is based on Raspbian, but there is no apt-get.

I have tried to deactivate the onboard wifi :

> more /boot/config.txt
# disable onboard wifi & bt
dtoverlay=sdhost
dtoverlay=pi3-disable-bt-overlay

I have checked that the dongle is detected; I seem to have 2 wifi interfaces but I don't know which one is the dongle, and it seems that the onboard wifi is not in fact disabled:

> ifconfig -a
eth0      Link encap:Ethernet  HWaddr B8:27:EB:2A:03:3A  
          inet addr:192.168.1.20  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ba27:ebff:fe2a:33a%1995107028/64 Scope:Link
          inet6 addr: 2a01:cb04:57e:4800:ba27:ebff:fe2a:33a%1995107028/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3396 errors:0 dropped:162 overruns:0 frame:0
          TX packets:1834 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1358952 (1.2 MiB)  TX bytes:275274 (268.8 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1%1995107028/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr B8:27:EB:7F:56:6F  
          inet6 addr: fe80::ba27:ebff:fe7f:566f%1995107028/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:3036 (2.9 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:13:EF:6B:30:0B  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I have also tried to configure the wlan interface (I have tried both wlan0 and wlan1):

>nano /etc/network/interfaces
# Configure Loopback
auto lo
iface lo inet loopback

iface eth0 inet dhcp
#auto eth0

#allow-hotplug wlan0
#auto wlan0
#iface wlan0 inet dhcp

allow-hotplug wlan1
auto wlan1
iface wlan1 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

But when trying to get the wlan interfaces up (either 0 or 1) it fails:

> ifup wlan1
udhcpc (v1.24.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing

One precision : I am doing that over ssh with an ethernet cable plugged in, because I don't have a USB keyboard. Maybe I should find a keyboard and remove the ethernet cable ?

I am not very well versed in linux so I'm not sure what I'm doing wrong.

  • How can I check if my wifi dongle is properly detected ?
  • How can I make sure my onboard wifi is disabled ?
  • Obviously, how can I make my dongle work ?
  • 1
    The first six hex digits of HWaddr (MAC) show the Manufacturer, so wlan0 is the internal one, having the same 6 digits (B8:27:EB) as eth0. wlan1 is (00:13:EF) Kingjon Digital Technology Co.,Ltd. wlan1 hasn't an ip address assigned. Don't know anything about recalbox and RasPi integration. – LotPings Mar 17 '17 at 22:39
0

I have never heard of Recalbox, but if it lacks apt-get is seems unlikely it is based on Raspbian, or any other Debian distribution.

On Raspbian to turn off wifi, rfkill block wifi; to turn it on, rfkill unblock wifi. For Bluetooth, rfkill block bluetooth and rfkill unblock bluetooth.

Your /etc/network/interfaces is inconsistent, and is not allocating IP addresses to wlan. See How do I set up networking/WiFi/Static IP, although this is for Raspbian. There are many different networking systems used on other distributions.

  • Does the rfkill command just turns off the onboard wifi ? Thanks, if I can't make it work on recalbox I'll try it on raspbian, just to check if the dongle is compatible with the pi. – thomasb Mar 18 '17 at 8:55
  • I have not used it myself, it is a standard Linux tool to manage the kernel service. man rfkill should provide more detail, and should enable control of specific interfaces. – Milliways Mar 18 '17 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.