1

I guess it is because I have logged out it once by accident. and the pi now cannot get any wifi network and just shows "no AP found scanning" I have tried to do the command "sudo ifdown wlan0 && sudo ifup wlan0" and it shows "No wireless interfaces found". I also tried (sudo) iwlist wlan0 scan and it shows "No scan results" both.

Anyone can help?

  • after I changing "iface wlan0 inet manual" to "iface wlan0 inet dhcp" now the network shows"No wireless interfaces found" only – Herschel Mar 20 '17 at 18:44
  • and another question is I can't get my ip address by using command of "ifconfig". no ip address shows there. and essid shows off/any if i input iwconfig – Herschel Mar 20 '17 at 18:47
1

the result is that there is something wrong on my hardware...

  • Then this likely won't help anyone. Update your original question, or delete it – ElefantPhace Mar 28 '17 at 1:14
0

I see what you have tried, and would suggest you use this command:

sudo wicd-curses

It will help you figure out your connections. Point to the one you want and use config to get the password and router IP entered. Make sure you're on the right interface under Prefs. Then try Connect.

As you make changes, use ifconfig to see the results.

Sometimes a reboot is required before they take hold, since curses is changing the configuration files.

  • Thank you for your help. But I haven't installed wicd and there's no network so ......:((( – Herschel Mar 20 '17 at 17:34
0

After booting up you pi go to the upper right of your display and click on the Wi-Fi icon enter your Wi-Fi info; ie your ssid and password and you will be on your way. If your pi does have Wi-Fi then attach a Wi-Fi dongle before inputting the info.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.