0

I edited this file in hopes of getting a command to run at startup of the GUI in Raspbian:

/home/pi/.config/lxsession/LXDE-pi/autostart

I added this line:

@/home/pi/startup.sh

which contains the following:

lxterminal
/usr/local/bin/synergyc <server ip address>

lxterminal does open as expected, but the command to start synergy as a client does not work. I already gave the server a static ip and already began running synergy on the server. It works if I manually enter the full synergyc command after startup.

1 Answer 1

1

I figured out that I could use an option in the lxterminal command to run the desired synergy command:

lxterminal -l -e '/usr/local/bin/synergyc <server ip address> ; /bin/sh '

The only thing I'm trying to work out is how to avoid this -l option and still have the terminal open, rather than just flash open and close.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Commented Jan 16, 2020 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.