1

Every time I use odoo posbox image on the raspberry, I can't use the sudo command, did I miss something?

Odoo posbox image

1

I am using posbox image in pi in Linux. You are using wrong command. Don't need to use command : sudo apt-get update Here "update" command won't work. That's why you are getting base error. Try with some else command. Because "sudo" is working in pi.

| improve this answer | |
1

In your picture it is the Pi part of the command that bash is complaining about.

The sudo command gives the current user root privileges and does not need to be told what user you are. You can state the user with sudo -u user If you do not want to be root (for example www-data).

See here for a quick overview of sudo and here for an overview of users and groups.

One minor point - if you are using the command line to update, it’s now better to use apt than apt-get as it gives more feedback. apt-get is now being used for automated updates.

A simple way to bring the system up to date is:

sudo apt update && sudo apt -y upgrade

This updates the repository list and if (and ONLY if) that has run fine, downloads and automatically installs the latest versions from the repository.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.