2

I have tried to use this guide to use an external hard disk connected to a Raspberry Pi as a time machine. It succeeded in that I have made the Raspberry Pi visible on my mac, so that I am able to connect to "Time Machine" here. However, the size of this disk is app. 120 GB, which is equivalent to the memory card of the Pi. I would expect that it would be equivalent to 1TB, which is the size of the external hard disk.

I have tried to undo everything and follow the guide again, but the problem still persists. I have also tried to verify that the disk permissions on the external disk are correct, i.e. 777.

A speculative hypothesis is that I have somewhere mixed the memory card of the Pi and the external disk, but not sure how to verify this.

Any hints on where I could be going wrong?

2

It sounds like you failed to mount the drive in the right place (in your guide that's /media/tm). Without the mount in place your mounpoint (the directory where you want to mount the drive) is just a regular directory on the SD card, that's why you see the disk size of your SD card when you're trying to use it.

I suggest you try to make a backup from your Mac (is it possible to backup a single file?) and check where the backup files are created on the SD card. Then run the mount command and check to which directory your drive is mounted. Hopefully you'll see a discrepancy, and your issue will be resolved once you correct it.

  • 1
    Yes! Also found out that I have put sda and not sda2 in fstab, so efter a restart, a umount -a and then a mount -a it worked... – avriis Mar 21 '17 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.