1

Setting up SSH over wifi with new Raspberry Pi Zero. I installed an Edimax wifi adapter, ran raspi-config to enable ssh, and edited /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf in the same way as I have done with 4 Raspberry Pi Model B+ units currently in my network.

The Zero boots up with a pingable wifi address (configured as static).

The Zero is refusing an SSH connection: when I attempt from Putty I immediately get:

network error: software caused connection abort

Tried the Putty connection from another windows host with the same result. When I attempt from another pi (ssh username@ip_address) I get:

Read from socket failed: Connection reset by peer.

The error is immediate, and happens every time. There are no firewall or router issues; these are all on one subnet (other SSH sessions to Pis are on wired network, not wifi).

I am sure SSH is enabled (ps aux | grep sshd) and listening on port 22 (netstat -plant | grep :22).

I can ping this new pi over wifi, but can't establish the SSH session. Is there some limitation to the Pi Zero I don't know about? Or problems with SSH over wifi?

The only thing different about this Pi (other than it's a zero) is that it only has access to the local network via wifi.

EDIT: I have the latest JessieLite distribution 2017-03-02.

  • To rule out the obvious have you rebooted? – Steve Robillard Mar 24 '17 at 21:41
  • yes; I have only the one USB port so I have to swap out keyboard/edimax and reboot each time – user3235770 Mar 24 '17 at 22:07
  • Do you happened to have another device that using the same IP that is in conflict with your Pi zero's static IP? – hcheung Mar 25 '17 at 3:47
  • No, using IP Scanner shows no conflicts. I did, however, have two different IP addresses on this pi associated with wlan0; this was because I had a static ip specified both in /etc/network/interfaces and /etc/dhcpcd.conf. Removed one of them and I was down to one IP, but the problem persists. – user3235770 Mar 25 '17 at 13:21
2

I had the same problem as you, and following the instructions in this thread worked for me.

so do

sudo rm /etc/ssh/ssh_host_*

sudo dpkg-reconfigure openssh-server

This will rebuild the ssh keys and config. Hopefully it works for you as well.

  • fixed it for me. This was so frustrating! – steampowered Oct 4 '18 at 16:50
1

As of the November 2016 release, Raspbian has the SSH server disabled by default. It can be enabled manually from the desktop or by raspi-config.

  • he said in his original post he enabled ssh via raspi-config – steampowered Oct 4 '18 at 16:43
0

If your Rpi partitions are stored on either a (micro)SD card and/or a USB memory stick, mount its boot partition on a computer and use the touch utility to create an empty file with a name ssh. Once done, execute sync before unmounting the partition. Then, take it to your Rpi device to boot. Once booted, hopefully you should have no problem to SSH into your Rpi device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.