2

Using the Compute Module & IO Board, I installed uv4l. I'm just not sure why this "software by http://linux-project.org" watermark showed up only when I use Stereoscopic Vision.

(No watermark when I use Dual Cameras separately: https://www.linux-projects.org/uv4l/tutorials/dual-cameras/)

enter image description here

Is there a way that I could hide/remove the watermark?

Also the stream itself works, but I can't get webrtc to work for dual camera at all.

2
  • try setting –text-annotation-background no and –text-overlay disabled, but sounds like a bug
    – rob
    Mar 27 '17 at 13:00
  • 1
    According to the developer feedback, "watermark on the compute module can be removed if UV4L is intended to be used commercially"....
    – l489977
    Mar 28 '17 at 5:11
1

Instead of using uv4l's raspicam driver to driver the raspberry pi camera, you can use the kernel-based bcm2835-v4l2 driver. Just modprobe it and enable it using raspi-config, and you should have a /dev/video0 file.

After the device file appears, you can start uv4l with these options:

uv4l --external-driver --device-name=video0

The text overlay will be gone, and the rest of uv4l's features should work.

0

Set the following in motion.conf and it will be removed:

v4l2_palette 8
0

None of these worked for me.

Send a mail to info@linux.org asking them to remove the watermark stating the reason you are using for (project/thesis/commercial). They will ask you to mail the output of uv4l driver serial number provided you give credits in which you use it for.

0

Since no one did provide a step by step solution, let me help you out.

In my case, uv4l installed with a service running at boot. I wrote another service, but a quick and easy way is to edit the service installed by uv4l.

sudo nano /etc/systemd/system/uv4l_raspicam.service

Now change this:

ExecStart=/usr/bin/uv4l -f -k --sched-fifo --mem-lock --config-file=/etc/uv4l/uv4l-raspicam.conf --driver raspicam --driver-config-file=/etc/uv4l/uv4l-raspicam.conf --server-option=--editable-config-file=/etc/uv4l/uv4l-raspicam.conf

into this:

ExecStart=/usr/bin/uv4l -f -k --sched-fifo --mem-lock --config-file=/etc/uv4l/uv4l-raspicam.conf --external-driver --device-name=video0 --server-option=--editable-config-file=/etc/uv4l/uv4l-raspicam.conf

Reload the systemctl daemon:

sudo systemctl daemon-reload

Restart the service:

sudo service uv4l_raspicam restart 

Check the status:

sudo service uv4l_raspicam status

Last line should state something similar to:

May 13 12:02:00 raspberrypi uv4l[7155]: <notice> [driver] Using video device /dev/video0

I hope I helped a lot of you :)

-1

Just use sudo modprobe bcm2835-v4l2 and change the input device to /dev/video0.

1
  • This is exactly what the top-voted answer suggests. Jul 5 '19 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.