1

I have a raspberry pi 2 model B installed Raspebian powered via adapter of 5V and 750mAh. It is used to control 3 stepper motors via DIY motor driver circuits on GPIO pins powered by an external power source of 20V.

https://www.raspberrypi.org/forums/viewtopic.php?f=49&t=55580 is the guide I'm using for a single motor.

The issue here is that when I connect the power supply common ground to raspberry pi, the power supply voltage drops to 9V for 1 motor. It drops to 6.5V for 2 motors and 5.8V when all three are connected.

I have tried Arduino input to circuit with its common ground and that drives all motors successfully without any drop. I have tried the GPIO of Raspberry Pi and common ground of Arduino but it gives the drop all the same.

I have tried other power sources like 12V and 32V for motors and the drop is exactly the same i.e. 9V, 6.5V and 5.8V for 1,2 and 3 motors connected at a time respectively. Changing power sources of Raspberry Pi didn't help either.

I have tried different ground pins, the issue persists.

I need a significant voltage for the motors and a common ground is also necessary but everything I've tried so far hasn't helped.

All motors are bipolar.

Any other possible solutions? Or where should I look for the problem?

migrated from stackoverflow.com Mar 26 '17 at 11:17

This question came from our site for professional and enthusiast programmers.

  • I really don't see how connecting the grounds of the Pi and the power supply can exhibit the symptoms you mention. The most likely explanation is you are measuring the voltage incorrectly or bad wiring. Could you include a photo of the wiring you use with the Pi? – joan Mar 26 '17 at 11:31
  • It might not be possible to provide a picture but no, voltage is measured correctly. I have a Digital Multimeter for real-time measurement. The power supply has a digital display and is verified. – Mashal Rashid Mar 26 '17 at 12:08
  • 1
    The issue is resolved by raspberrypi.org/forums/viewtopic.php?f=44&t=35321 Apparently, on boot, a few pins are high and that somehow was causing the said problem. – Mashal Rashid Mar 26 '17 at 12:08
  • @MashalRashid Could you post the relevent details in an answer (attributing to the posters in the Raspberry Pi forums), please? – Toothbrush Mar 27 '17 at 10:15
0

https://www.raspberrypi.org/forums/viewtopic.php?f=44&t=35321

After thorough research, it turns out that certain Raspberry Pi pins are High on boot time providing negative voltage in the circuit. Though not too high, but enough make the certain voltage drop.

Changing the connected pins worked out; don't know if the boot configuration can be modified though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.