I have this Raspberry Pi 3 and I haven't used it in 2-3 months but I wanted to revive it by using it as a Home server. So, I booted it up with my Power supply and it tries to boot and after couple of seconds, it keeps on rebooting. I thought my power supply wasn't enough, so I tried it on my Raspberry Pi 2 and it worked fine! I even thought it was a problem with the SD card but it booted fine on my Raspberry Pi 2. Any help would be appreciated!

Thanks, Randy

  • 1
    It may be the power supply as the Pi3 needs more power than the Pi2.
    – joan
    Mar 28, 2017 at 0:49
  • A slightly defective USB cable could do this also.
    – NomadMaker
    Jun 6, 2018 at 0:40

1 Answer 1


Is a rainbow square visible on the top right hand side? If so, it is a power issue, you should probably try using a different adapter. For best results, use one rated at least 5V 2A (but you mentioned your other Pi works, so this is unlikely).

To make sure it's not a corrupt file system/SD card try getting a brand new SD card and flashing a new OS.

The Pi2/Pi3 OS should be interchangeable but I would definitely run a sudo apt-get update and a sudo apt-get dist-upgrade, to make sure it's on the latest firmware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.