I ordered a Raspberry Pi Zero W. I have an 8 GB size SD card, I have installed the newest Raspbian on it, but it isn't booting. I tried with NOOBS and Raspbian lite too. There is no fail/success boot indication on leds. What could I do? Probably bad SD card, or could be my Pi faulty? I have read that, all of the raspberries tested in factory before release, so I think the chance is small.

Sadly, I don't have any other raspberry to test the SD card.

Any suggestions?

  • What makes you think it didn't boot? Did you try to connect the pi to a screen via HDMI? Did you try the serial terminal? – Bex Mar 29 '17 at 10:37
  • Are there ANY LEDs active? If so, which ones (and how they are on {i.e. blinking red})? – user61421 Apr 1 '17 at 12:32
  • No, there isn't any LED activity :( – Attila Kis Apr 1 '17 at 15:19
  • 3
    Did usb PWR connected to the right place ? ( lower on ) – Guy . D May 19 '18 at 9:31

You don't say if you have an HDMI monitor plugged into the Zero, but for initial startup you really should. And a powered USB hub for a keyboard and mouse. Get the Pi working before you go headless.

If you do, then look at /boot/config.txt and try some of the suggestions there. If you plug the SD card into a PC you can edit the file with any text editor. (Not Word). Notepad should work.

hdmi_safe=1 is a good place to start. another is hdmi_force_hotplug=1

If you don't have an HDMI monitor around, try plugging in a composite monitor.

  • Sadly, I don't have any HDMI cable or HDMI monitor. I am trying to run in headless. But the main problem is, the indication led aren't working, non on fail boot or success boot. Could my SD card faulty? I formated into FAT32 fs . I am using rapsbian 2017-03-02 version. As far as I know, if the pi sucessfully boots, there must be an led indication. I burned my Image with Win32DiskImager – Attila Kis Mar 30 '17 at 8:42
  • Do you have a semi-modern TV set at hand, which often came with HDMI ports? Or you could try with one of those HDMI-to-VGA converters. However, if the green LED doesn't lit at all and then starts flashing irregularly, this is hard to diagnose. Even with an HDMI monitor attached you may not see anything before the Pis have successfully read the mSD. Can you try to reflash the card? Sometimed, I had boot issues which reflashing the same card again solved. Also try another card, if possible. You may try etcher.io for image writing. – TheDiveO Jul 9 '17 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.