2

I have Dell U2414H monitor which has two HDMI ports. The problem is RPi works only when connected to second HDMI port, while I had no luck trying to make it work on first port.

When I connect RPi to first port, I get blank screen and monitor goes into sleep mode/power saving mode.

I think it's not the problem with monitor, because when I connect my laptop to either of the ports it works flawlessly. Also RPi works fine when connected to two different TVs.

It's strange to me, because it's:

  • not RPi problem, because RPi works on 2 different TVs and one of the HDMI ports of monitor
  • not monitor problem, because when I connect laptop then both HDMI ports work
  • not cable problem

How can I diagnose this issue and possibly fix it?

1

Your monitor seems to output incorrect EDID on the first HDMI input. I suggest you configure your RPi to use the right EDID:

  1. Connect your RPi to the working port and run tvservice -d edid.dat

  2. Place edid.dat on the boot partition and set hdmi_edid_file=1 in config.txt

Alternatively, you can ignore EDID altogether using hdmi_ignore_edid or hdmi_safe settings.

If you want to get to the root cause of your issue, read EDID while connected to each port of your monitor, run these files through edidparser and compare.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.