1

I am pretty new to Raspberry Pi and I am trying to permanently mount an external HD. I am running Raspian on a Pi 3. I have installed Plex and intend to use this drive, which already contains my media, as the drive for the server.

The drive is this type:

/dev/sda1: LABEL="extsmall" UUID="3721afc7-bdb1-4979-8349-abc18f378896" TYPE="ext4" PARTUUID="b71d3e39-01"

I ran the sudo ls -l /dev/disk/by-uuid/ which returned this:

    lrwxrwxrwx 1 root root 15 Mar 28 22:01 3461-3439 -> ../../mmcblk0p1
    lrwxrwxrwx 1 root root 10 Mar 28 22:01 3721afc7-bdb1-4979-8349-abc18f378896 -> ../../sda1
    lrwxrwxrwx 1 root root 15 Mar 28 22:01 540aa4bc-b2c7-4894-9f03-ffc7aabfc110 -> ../../mmcblk0p5
    lrwxrwxrwx 1 root root 15 Mar 28 22:01 91E2-DB03 -> ../../mmcblk0p6
    lrwxrwxrwx 1 root root 15 Mar 28 22:01 e2b3289b-6c40-404a-9059-57813cce2039 -> ../../mmcblk0p7

I edited fstab by adding this line:

UUID=3721afc7-bdb1-4979-8349-abc18f378896    /mnt/usbstorage    ext4   nofail,uid=pi,gid=pi $

I still cannot see the HD when I run cd /mnt/usbstorage then ls. In addition, I cannot see anything in that directory when running the GUI.

11
  • The output of mount with no arguments is more definitive than cd ...; ls. I don't think auto is required as an option, but you could try it (since noauto is also an option, it's implied auto is for something). You may want to check that before and after a call to mount -a (see man mount and man fstab). Although it's not related to your problem, you probably also want async and noatime with an ext4 fs.
    – goldilocks
    Mar 29, 2017 at 14:28
  • Like I said, I'm new to Raspberry Pi. I'm only slightly less new to Linux, in general. Can you provide some specific steps to follow?
    – SteveC
    Mar 29, 2017 at 14:33
  • Well, sudo mount -a should mount everything in fstab that doesn't have the noauto keyword. I believe that's exactly what happens at boot (but the question then remains, what is auto for?). Plain mount (you don't need sudo) will show everything that's mounted; it doesn't show UUIDs, but it will show the mount points (and the list should be easy enough to skim through). So you can fiddle with fstab and use sudo mount -a and check with mount without having to reboot...
    – goldilocks
    Mar 29, 2017 at 14:50
  • ...If the mounting doesn't happen, have a look at journalctl | tail -n 40 right after you try to see if any errors are logged by the system.
    – goldilocks
    Mar 29, 2017 at 14:50
  • I simply added sudo mount -a to fstab. The only change to the output to mount is that the line gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000) appears in the output before the change. There are no errors logged from the journalctl | tail -n 40 command.
    – SteveC
    Mar 29, 2017 at 16:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.