2

Edit: there is an update on the bottom. I managed to resolve one issue but the behavior changed to be more consistent, even though it still doesn't work properly.

Problem: I am creating a kiosk to be used as the HMI for a rather complex system (irrelevant). I am using a Raspberry Pi 3 with a touchscreen as the kiosk, it will be fed a page from another system with a web server. I did all of my testing with a third party 10" screen, and then switched to the Official 7" Raspberry Pi Touchscreen in an effort to reduce costs. I can not get touch scrolling working well on the 7" screen.

Setup:

  • Raspberry Pi 3 running Raspbian Jessie
  • chromium-browser w/ chromeTouch and Touchscreen Keyboard extensions
  • Screen 1 - FDI 10.1" Capacitive Touchscreen
  • Screen 2 - Official Raspberry Pi 7" Touchscreen

It's a simple setup, chromium starts automatically at launch and displays the page.

Results on Screen 1:

  • Scrolling vertically with no issues, is consistent after page reloads, reboots, etc.
  • Scrolling horizontally through a carousel of images with no issues.

Results on Screen 2 (the problem!):

  • Scrolling vertically only works if the scrollbar is visible (I would prefer to hide it using an option in chromeTouch)
    • sometimes it doesn't work at all, but will work after I refresh the page. Maybe.
    • doesn't work at all when chromium is in kiosk mode or fullscreen.
  • Scrolling horizontally through the carousel has only worked once. I am not sure why, since I didn't change anything.

I have tried:

  • finding differences in /boot/config.txt and using values from Screen 1 to see if they will help Screen 2.
  • changing settings in chromeTouch to get a more consistent result. No luck.
  • using the same image from the RPi on Screen 1 in the RPi on Screen 2.
  • rebuilding the kiosk platform one step at a time to see what breaks the touch function. It turns out the touch function just doesn't work.

Any tips or ideas of what to try next would be greatly appreciated!

Edit: I had installed the 7" Touchscreen to the RPi using the yellow and green wires on the GPIO, where I found out (here) that this isn't necessary in any model B Pi. This made the problem a lot more consistent, which is nice, but doesn't completely resolve the issue:

New behavior:

  • first tap opens to target page, which includes an image carousel. Vertical scrolling works without issue. Can not scroll horizontally through image carousel - this is important to this kiosk project.
    • I can refresh this tab as many times as I want with no change.
  • if I open the same target page in a second tab, I can scroll both vertically through the page and horizontally through the image carousel.

I no longer believe this to be an issue with the touchscreen, however it still bugs me that the FDI 10.1" screen works without issue regardless of which tab is open. Should I be investigating chromium at this point?

If this can be moved to another stack please let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.