-2

I have an external HDD formatted in NTFS connected to my raspberry. I need to clear some space on it but, although I have all the permission and pi is the owner of most of the directories, when i execute a rm -rf on a directory this message appear

rm: can not remove "path": Operation not permitted

this is the situation after a ls -lah

totale 559M
drwx------  1 pi   pi    12K lug 25  2016 .
drwxr-x---+ 3 root root 4,0K mar 30 21:55 ..
drwx------  1 pi   pi   4,0K giu  1  2016 Develop
drwx------  1 pi   pi   4,0K mag  8  2014 Documenti
-rw-------  2 pi   pi    104 lug 27  2013 .dropbox.device
drwx------  1 pi   pi   136K nov 21 22:06 Video
drwx------  1 pi   pi   4,0K giu  1  2016 Programmi
drwx------  1 pi   pi      0 lug 25  2016 $RECYCLE.BIN
drwx------  1 pi   pi   8,0K nov 21 22:54 Foto
-rw-------  2 pi   pi   444M ago 22  2015 Foto guida.avi
drwx------  1 pi   pi   4,0K lug 18  2015 Foto_guida_IMGS
drwx------  1 pi   pi   4,0K ago 22  2015 System Volume Information
-rw-------  2 pi   pi   115M giu 23  2014 document.pdf

and this is the result of a mount command

/dev/mmcblk0p2 on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=469532k,nr_inodes=117383,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
tmpfs on /run/user/114 type tmpfs (rw,nosuid,nodev,relatime,size=94776k,mode=700,uid=114,gid=65534)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=94776k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sda1 on /media/pi/dIVANO2TB type ntfs (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0177,dmask=077,nls=utf8,errors=continue,mft_zone_multiplier=1,uhelper=udisks2)

someone can help me please

  • 1
    What was the actual command you used? – Jacobm001 Mar 30 '17 at 23:16
  • For try to delete? rm - rf folderName i have tryed with and without sudo but the result is the same – Ivan Notarstefano Mar 31 '17 at 6:03
  • Also add the output of your mount command (maybe you have mounted read-only?). And please copy-paste the text instead of a screenshot if possible. – Dmitry Grigoryev Mar 31 '17 at 8:14
  • @DmitryGrigoryev i have edited the post – Ivan Notarstefano Mar 31 '17 at 17:18
0

Based on this answer:

I believe you're using the wrong identifier for the NTFS file system in your mount command and that's why it's mounting as read-only. First, make sure you have installed the ntfs-3g package by running sudo apt-get install ntfs-3g (to be able to enable write access to NTFS volumes). Then modify ntfs to ntfs-3g in the following line:

/dev/sda1 on /media/pi/dIVANO2TB type ntfs (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0177,dmask=077,nls=utf8,errors=continue,mft_zone_multiplier=1,uhelper=udisks2)

Now reboot your Raspberry Pi and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.