1

I'm trying to install the ppp packaged for the raspberry pi so i can connect a 3g dongle to the internet but i get the following error. It seems that some modules install except one. overall the ppp package doesn't install. How can this error be solved? Thanks!

 Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  javascript-common libc-ares-dev libc-ares2 libev-dev libev4 libv8-3.8.9.20
  libv8-dev node-node-uuid wwwconfig-common
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  ppp
0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B/351 kB of archives.
After this operation, 651 kB of additional disk space will be used.
(Reading database ... 99990 files and directories currently installed.)
Unpacking ppp (from .../ppp_2.4.5-5.1+deb7u2_armhf.deb) ...
update-rc.d: using dependency based boot sequencing
insserv: warning: script 'S99runmbbservice' missing LSB tags and overrides
insserv: warning: script 'runmbbservice' missing LSB tags and overrides
insserv: There is a loop at service runmbbservice if started
insserv: There is a loop between service plymouth and mountnfs if started
insserv:  loop involving service mountnfs at depth 7
insserv:  loop involving service networking at depth 6
insserv: There is a loop between service runmbbservice and mountall if started
insserv:  loop involving service mountall at depth 5
insserv:  loop involving service checkroot-bootclean at depth 4
insserv:  loop involving service urandom at depth 7
insserv:  loop involving service checkfs at depth 5
insserv: There is a loop at service plymouth if started
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Starting runmbbservice depends on plymouth and therefore on system facility `$all' which can not be true!
insserv: Max recursions depth 99 reached
insserv: There is a loop between service runmbbservice and mountall-bootclean if started
insserv:  loop involving service mountall-bootclean at depth 7
insserv: There is a loop between service plymouth and mountnfs-bootclean if started
insserv:  loop involving service mountnfs-bootclean at depth 1
insserv: There is a loop between service runmbbservice and mountkernfs if started
insserv:  loop involving service mountkernfs at depth 1
insserv:  loop involving service runmbbservice at depth 1
insserv:  loop involving service kbd at depth 9
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing /var/cache/apt/archives/ppp_2.4.5-5.1+deb7u2_armhf.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /var/cache/apt/archives/ppp_2.4.5-5.1+deb7u2_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • 1
    So i've solved it. The problem is that there are empty files that should be removed, one of them is runmbbservice, – Brian Formento Apr 2 '17 at 16:21
  • Do you have manufacturer's instructions? – SDsolar Jul 29 '17 at 21:46
4

Clearly it is showing you that this package is missing dependencies. You need to make sure you update your packages and preferably use a package manager that handles dependencies better. Try this

pi@raspberrypi:~$ sudo su -
root@raspberrypi:~# apt-get update && apt-get install aptitude
root@raspberrypi:~# aptitude upgrade && dpkg --configure -a && aptitude install ppp
1

I am not a Linux guru but I've be using RPi for a couple years:

Did you did you do sudo apt-update before trying to do your install? I think you want to do this before any kind of upgrade to get the latest package lists so the update process knows where to get all the right stuff.

I would also do "sudo apt-get autoremove" to get rid of those unrequired packages it is telling you about. Why carry around unneeded garbage?

Then, have you done "sudo apt-get upgrade" lately, or are you not doing it intentionally? i.e. from fear of it messing something up? I guess I am in the habit of trying to get the whole system up-to-date before I try to add something new.

  • I've just tried that and it doesn't solve it :/ even by removing the unneeded files – Brian Formento Apr 1 '17 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.