2

I would like to access my RPi on my local network by a FQDN that I have. Example: my home network can be reached at www.myhome.com and that in turn with port forwarding will reach my RPi internally at 192.168.1.100 (set statically in the router/RPi)

From internally I would like to reach the same RPi at its FQDN of rpi.myhome.com. Since the hostname = rpi and the static IP = 192.168.1.100 it seems like just adding to the /etc/hosts with the entry: 192.168.1.100 rpi.myhome.com Should accomplish this. BUT... that's not the case. I can't seem to get around the problem that any hostname get the .local appended to it via the avahi deamon. So all local request end up as rpi.local.

I can set local DNS in my router I think, it's a Verizon FIOS router. But the problem of .local still exist.

Looking for suggestions.

  • The resolv.conf has my DNS IPs correct and the local FQDN already there so I don't think that's an issue - the nsswitch.conf I have no idea what that does? – BarclayVision Apr 1 '17 at 17:11
  • Also try changing your /etc/hostname to rpi.home.com and do hostname -F /etc/hostname and then reboot – Shan-Desai Apr 1 '17 at 17:12
  • nsswitch.conf file is used for you name service configuration. Try man nsswitch.conf to get more details – Shan-Desai Apr 1 '17 at 17:14
  • have tried renaming hostname: rip.home.com and cannot resolve dns, tried to ping rpi.home.com and timeout - not sure where DNS is taking place - hosts file is set to 192.168.1.100 rpi.home.com so I don't think its there ? Have also setup DNS server in router for local IPs and still no resolution. – BarclayVision Apr 1 '17 at 17:54
  • Another issue I'm finding: on the RPi box, if I go to 127.0.0.1 the browser URL always shows "raspberry.local" - I don't think this is cached, so where is it still getting this from? – BarclayVision Apr 1 '17 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.