0

I just got two micro sd cards, I wrote latest jessy raspbian on the first, then pluged it into the Pi, it was good until I unplug it from the Pi, then trying to open it again on my PC, the PC could not detect it (windows, ubuntu, and my android phone none of them detected the card) I then resigned to the fact that the card may be just dead. and tryed with the 2nd sd card, same thing happened.

And when I plug back the cards on the raspberry, raspberry does not boot.

So, what do you think about that. Any idea about how can I fix my cards or how can I run latest jessy and be able to unplug the card and use it somewhere else. I am affraid to try other cards, because it might just happen again (if it happens twice I don't see why it won't happen the third time)

I noticed this behavior: When I open device managment,and then plug the card it shows as USB mass storage for few seconds then disappears. same on disk management

Thanks a lot for your help

  • Plugging your card into a working Linux system would be helpful to diagnose this. Unlike windows, Linux gives you an error message when a device malfunctions. – Dmitry Grigoryev Apr 5 '17 at 15:45
  • Linux (ubuntu) can't detect the card, and android can't detect the card. all I got in disk management on ubuntu is no media, when attempting to eject the medium inside the adaptor, I got: udisks-error-quark, 0 – Tarik Mokafih Apr 5 '17 at 17:26
  • But what does Linux tell when you plug the card in? There should be something in the logs, unless the card is totally dead. – Dmitry Grigoryev Apr 5 '17 at 18:15
  • which logs are talking about please ? – Tarik Mokafih Apr 5 '17 at 18:22
0

It sounds like you've lost the partition table.

You can repair your SD card with a built-in windows utility called diskpart: instructions here.

Summary:

from the run menu, run diskpart

in diskpart:

execute list disk

select your sd card eg. select disk 1 if it appears as disk 1

execute: clean

execute: create partition primary

If either command fails, just reattempt it. Sometimes they fail the first try.

quit diskpart. Your SD card will appear in the explorer. Try to open your SD card, you will be prompted to format it.


Are you making sure to safely shutdown your Pi before you pull the SD card out? You should always have access on Windows to the ~100MB boot partition of an SD card running Raspbian

  • neither clean nor create partition primary worked after many many attemps – Tarik Mokafih Apr 5 '17 at 12:15
  • When I open device managment,and then plug the card it shows as USB mass storage for few seconds then disappears. same on disk management – Tarik Mokafih Apr 5 '17 at 13:01
  • I had an SD card unreadable like this. I used Etcher to flash another image on the card and it was fine. – NomadMaker Jan 23 '18 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.