5

I have been using Sonic Pi recently and have been annoyed by a persistent stream of white noise. This has happened on both Raspbian and Ubuntu MATE 16.04 for Raspberry Pi, using SENNHEISER MX356s. Is there any way to stop this?

  • 1
    There have been a lot of observations made here that the Pi's audio, particularly through the 3.5mm jack, is not great, and subject to various kinds of interference and noise. – goldilocks Apr 5 '17 at 18:34
  • I'm using a PiCamera and a Button on GPIO 21 – R Harrington Apr 5 '17 at 18:44
  • 1
    I think it applies regardless of what you have connected. It's just a crappy audio system that's not properly isolated. If someone asked me, "Is this a good thing to buy if I want to use it primary to play music?", I'd say no. – goldilocks Apr 5 '17 at 18:47
4

Per the comments below the question, the Pi's 3.5mm audio output is not a good output. I try to avoid it where possible. I have yet to see a convincing writeup of any approaches which would eliminate the noise from the analogue jack sufficiently for it to be used for enjoying music.

Your options for usable audio are:

I've tested a few variations on each of these approaches, and they all seem to work fine.

2

The question is a bit old, but nevertheless: Add

audio_pwm_mode=2

to /boot/config.txt

(Source: https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=136445, worked with my pi)

  • Works like a charm! – Morgoth Jan 24 '18 at 14:31
0

Try burning another SD card with a different OS. I get white noise and static on Raspbian Stretch, but I used a different OS a very long time ago (Kano OS) and the audio quality was perfect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.