I'm trying to install the RTL8812au drivers for a wireless usb adapter. My error is very similar to another question.

Missing build file when building for rtl8812au driver

However, the solution does not work for my version kernel version 4.4.50-v7 (found by running uname -a)

I configure the Makefile to ARM_RPI=y and I386_PC=n and run make then I get the following error.

make[1]: *** /lib/modules/4.4.50-v7+/build: No such file or directory. Stop. Makefile:1052: recipe for target 'modules' failed


1 Answer 1


Literally the very next thing I tried worked. I spent the last 5 hours working on this so I'll go ahead and share what I did to fix.

First, I sourced my drivers from the following github repo.

sudo git clone https://github.com/gnab/rtl8812au.git

cd rtl8812au

modified the Makefile

sudo nano Makefile



Ctrl + X, Enter to exit and save

then ran

sudo chmod +x install.sh

This next step was critical for getting the make to work on my machine. Before running make or install.sh I had to install raspberrypi kernel headers and build essential

sudo apt-get install raspberrypi-kernel-headers build-essential

then instead of manually running make I decided to use the automated install file.

sudo ./install.sh <--- This is where the error occurred before. Now that you installed the RaspberryPi Kernel Headers it works.

Finally, I shutdown the device. Plugged in my Realtek Wifi Adapter and booted it and it connected with my preset wifi settings.

Not the answer you're looking for? Browse other questions tagged or ask your own question.