1

My raspberry pi zero w with latest version av Raspbian Jessi worked fine yesterday and i had no problems to ssh to it from my windows 10 pc. Today i updated it with:

sudo apt-get update && sudo apt-get dist-upgrade -y

sudo reboot

After it is up again i am no longer able to ssh to it. I get the following error message when i try to ssh to it:

PuTTY Fatal Error

Network error: Software caused connection abort

I tried setting up enabling it again from raspi-config followed by a reboot, but that does not help.

Any suggestions as to how i can fix this problem?

Thank you.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Is the SSH daemon running on the Pi? What is the full error message from putty? – joan Apr 10 '17 at 18:53
  • Thank you for your response, Joan. I did not think it was relevant to mention it in my post, but the only thing that i left out from the putty error message i received was the "x" error icon in the message and the "OK" button, otherwise the error message that i received from it is exactly as i had posted. The daemon.log file indicated that the ssh daemon could not be run because of a key that was in the wrong format. Since this appeared to indicate that data has been corrupted on the disk i decided to make a clean start: clean the disk, reformat it (erase everything), and reimage the raspi. – raymond Apr 10 '17 at 19:27
0

It sounds as if you may not have enabled the SSH daemon. As a security measure ssh is off by default. You can enable it – for the next boot – by creating an empty file called ssh in the root of your boot device. The easiest way to do this is to mount the SD card on another computer and the create the file. The contents of the file are ignored and it is deleted at boot.

To make the change permanent:

  1. Run sudo raspi-config
  2. Select option 5 (Interfacing)
  3. Enable ssh
  4. Change your password (option 1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.