1

I have a Waveshare 3.2 inch touchscreen that I am using with a Raspberry Pi 3 and Raspbian OS. The screen works fine and I can toggle to a HDMI monitor and back with no problem. The problem I am having is that nothing fits on the 3.2inch display. Any window I open is too big and gets cut off on the right and bottom of the screen. What settings do I need to change in the /boot/config.txt file in order to make the windows stay within the 320x240 bounds of the touchscreen? Any and all input is appreciated.

  • Any luck on a solution? I have the same problem. – Gavin Simpson Aug 26 '17 at 18:32
1

I just found out a solution, if you're running a raspbian stretch (not lite) distro, you can simply go back to the terminal mode (cli mode) and enter the following command :

sudo apt-get --purge remove lightdm

This will remove the DE in which raspbian boots into, and then it will install the standard LXDE desktop environment, in which almost all the applications (not all, some of them still go out of the screen) will run within the screen itself, Good Luck! Trust me, it worked

Edit : The Default DE for raspbian stretch is PIXEL

  • That totally broke my pi (using a waveshare32b display). Had to start with startx and then the display didnt work properly. – Sandbird Apr 25 '18 at 17:02
  • @Sandbird It should load LXDE just like it did for me, is there anything specific that happened? I would like to help – Harsh Pherwani Apr 25 '18 at 17:12
  • Totally black screen, so i had no idea what was happening. I connected remotely with a console and started startx manually. After that i reinstalled lightdm, rebooted and at least i was able to get back to it, with a different desktop envir. though. At least from there i could change the resolution of the GUI somehow...not sure what i did exactly...but everything is super small, so now everything fits. – Sandbird Apr 26 '18 at 8:50
  • @Sandbird Dang, I'm sorry about that, but yes, with lightdm you can access LXDE the DE you're talking about, When I removed lightdm it directly took me to LXDE for some reasons without me needing to install lightdm again, LXDE is minimal and works great on a small screen – Harsh Pherwani Apr 26 '18 at 8:52
  • I am not so great when it come to linux, so maybe there was a simple solution to my black screen before i reinstalled lightdm...but worst case scenario this happens to somebody else, at least this way they can get to the same thing i did. Just play with the Desktop Environment and Settings, (i did try some stuff from rasp-config as well), not sure which value exactly changed my resolution to super small. Once i rebooted everything looked small enough to fit everything on screen..At that point i stopped :) – Sandbird Apr 26 '18 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.