3

I recently bought a RPi3. I also bought the CanaKit 5V 2.5A Raspberry Pi 3 Power Supply (https://www.amazon.com/gp/product/B00MARDJZ4/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1).

I am using NOOBS (https://www.raspberrypi.org/downloads/noobs/) and have it in the SDCARD. I tried several times but when ever I connect the board with the power supply, it doesn't detect the keyboard and the mouse. I don't even see the lights on Keyboard and Mouse. And I am stuck with it.

I can't move forward with out keyboard or mouse.

Any one faced this problem? Any solution?

This is where I am stuck. On this screen mouse or keyboard is not detected, hence I can't move forward.

I am shown this screen as soon as I power up the board

I tried as @Shaulinator suggested. But even after the boot, it just can't detect the keyboard or mouse. I am stuck on the below screen. And yes the mouse and keyboard are working fine. I cross checked.

enter image description here

What are the chances that the board might have problem. Shall I return it and get a replacement?

Finally the problem resolved. I used a DLink self powered USB hub. Thank you guys.

  • Can you tell us what LEDs light up on the Pi, and if the Pi successfully boots? Do any other USB devices work with your Pi? – Darth Vader Apr 11 '17 at 14:45
  • I see the LEDs near the power supply. I also see the LED if I insert an Ethernet cable. That's it. And yes it boots up too. – Naren Apr 11 '17 at 15:13
3

Here is the order of troubleshooting I would follow:

  • Verify you are on NOOBS 2.4.0, it is the latest install which you linked.

  • Plug the HDMI into the Pi and the monitor, plug the power into the Pi. Now confirm you can see picture and get input from the Pi, along with lights on the Pi after plugging in the power.

  • Plug in the mouse, are you able to see the mouse move around on the screen?
    • If not, try all four USB plugs with the mouse. If it still does not work, you should try to plug the mouse into another computer to confirm the mouse is working.
    • You should also grab one more wired basic mouse to connect to the USB of the Pi to confirm it's not the mouse.
  • If the issue still persists, my last resort would be to download Raspbian and mount the system image on the SD card after formatting it, and seeing if the mouse will work with Raspbian vs Noobs.

The rest of the steps come from this article and should be tried next.

Are you up to date?

Work on the USB driver and kernel happens frequently. You should use sudo apt-get update && sudo apt-get upgrade to get the latest firmware and kernel that will contain many patches not present in the default installs of Raspbian. If you are using a different distro on the Pi, then you should check around the distro's website or guides to see how to update it.

Does it enumerate?

If a device doesn't work, then the first step is to see if it is detected at all. There are two commands that can be entered into a terminal for this: lsusb and dmesg. The first will print out all devices attached to USB, whether they are actually recognised or not, and the second will print out the kernel message buffer (which can be quite big after booting: try doing sudo dmesg -C then plug in your device and retype dmesg to see new messages).

If there are errors with enumeration, then there are a few usual suspects:

Power

The Raspberry Pi's USB ports cannot provide enough current for high-power 500mA devices. You should use a good-quality powered hub when using these devices: some devices may advertise that they use lower power than they actually do, especially things like wireless LAN dongles and USB HDDs. Also, some hub power supplies advertise that they give out much more power than they actually can. Be sure to check your USB device with an alternative source of power: if you continue to receive the same result, you can rule power out as a cause of the issue.

Number of hubs

There is a limit to the number of cascaded hubs you can use with the Raspberry Pi. If your device refuses to work when used with a multi-port hub, then use lsusb -t to display a "tree" of which devices physically connect to what. There is always at least 1 hub in a model B: the ethernet chip is actually a 3-port hub and a USB ethernet device.

No drivers?

If a device enumerates without any errors, but doesn't appear to do anything, then it is likely there are no drivers installed for it. Search around based on the manufacturer's name for the device or the USB IDs that are displayed in lsusb (e.g. 05dc:a781). The device may not be supported with default Linux drivers, and you may need to download or compile your own third-party software.

Poor performance, but no errors in dmesg

First, be sure that it is actually the USB device itself which is causing the problem. Doing other activity such as other wireless devices using the same network, other devices using the USB bus may impact performance. Try to replicate the problem with a minimum number of other devices plugged in. Some devices can become flakey after a while because they heat up. For example, wireless LAN dongles can become quite warm if in constant use: try unplugging the device, leave it for a few minutes and plug back in. Does it still exhibit the same behaviour?

Device disconnects or continually reconnects

This again is usually caused by problems with power, so double-check your supply. If it's not power, then it can also be a symptom of getting too many errors from the device which causes Linux to reset the device. Try moving the device to a different hub port as described above.

  • @Naren I found this article. I'll update my steps with steps from it. – Shaulinator Apr 12 '17 at 14:20
0

I booted up raspbian-stretch-lite (2017-08-04) and found that my keyboard and mouse didn't work on my RPi 2. After some work, I discovered that the flimsy micro USB cable I was using to power the RPi could provide enough power to run the RPi but not enough to run anything plugged into the USB sockets.

protected by Community Mar 22 at 7:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.