4

I recently acquired a new Raspberry Pi camera module v2 to use with a Raspberry Pi Zero 1.3 and the 'official' Pi Zero case (comes with a 1.5" camera cable). I am running Raspbian Jessie Lite.

I have a good bit of familiarity with the Raspberry Pi platform and Linux in general (I just setup a 5x Pi 3 cluster for pyspark w/jupyter notebook in docker images, and I'm working on a Pi 3 + 4x Pi Zero cluster for mpich), so I thought this wouldn't be too difficult to setup.

Once I had everything plugged in, the Pi Zero with HDMI, a USB OTG connector + USB hub + WiFi adapter + keyboard/mouse adapter, power cable, and the camera ribbon cable, I ran:

raspistill -k

...and the output was a bunch of white and black vertical bars of varying thickness, and the output seemed to adjust if I waved my hand in front of the camera.

Is this defective hardware? What steps can I take to fix this if it is software related?

Here's an example of the image I took using the -o flag:

A bad raspicam image

2
  • Did you run it with the -k or -o flag? – Zimano Apr 12 '17 at 7:11
  • I ran the command both with the -k and -o flag, receiving identical output. A few days ago I had the chance to head back over to microcenter and get a replacement camera, and now everything works as it should. Thanks for the help! – Edenbaus Apr 24 '17 at 15:05
1

I had a not too dissimilar output when I was opening images and the dimensions were wrong, I used a V2 camera with some python bits set up for the V1 but there was an issue with ratios.

Could it be you have a version of raspistill which is using the V1 image size? The image size you've posted is 1902x1429 which i'm not spotting as a standard size.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.