1

I have a German keyboard on my Raspberry Pi 2B running Raspbian.

Any character that involves "Ctrl+Alt+key" doesn't work ([]@{}...).

I've tried all different keyboard layouts in raspi-config but none works.

My keyboard is a LogiLink ID0040.

The content of /etc/default/keyboard is :

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="nodeadkeys"
XKBOPTIONS="lv3:ralt_switch,terminate:ctrl_alt_bksp"

BACKSPACE="guess"

Thanks in advance for helping.

  • Have you tried AltGr+Key? AltGr is the key on the right side of the spacebar. – Dmitry Grigoryev Apr 12 '17 at 15:09
  • Also, could you run setxkbmap -query and post the results? – Dmitry Grigoryev Apr 12 '17 at 15:17
  • AltGr doesn't work either. The results of setxkbmap -query are: rules: evdev ; model: pc105 ; layout: de ; variant: legacy ; options: lv3:ralt_alt – Hugo Trombert Apr 12 '17 at 17:31
  • sudo dpkg-reconfigure keyboard-layout could work. I don't know maybe XKBMODEL="logicd" XKBLAYOUT="de" XKBVARIANT="" could be an approach. – Joe Platano Apr 13 '17 at 13:19
  • @JoePlatano this doesn't work either :| – Hugo Trombert Apr 13 '17 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.