2

chromium kept displaying ERR_NAME_RESOLUTION_FAILED.

  • The raspberry pi is connected in my laptop via Ethernet cable. I use advanced ip scanner, putty and xming. I already shared my wifi connection to other networks connected through my laptop but nothing works.
  • I also tried to use monitor and connected my rbpi to my router using the Ethernet cable. The wifi symbol can be seen at the top right and it is connected but when i open chrome, it still shows ERR_NAME_RESOLUTION.
  • I don't have a wifi adapter
  • I am new to raspberry pi
  • English is not my native language :D

Output of ifconfig:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:72:99:cb
          inet addr:192.168.137.7  Bcast:192.168.137.255  Mask:255.255.255.0
          inet6 addr: fe80::b0cd:6202:760a:b914/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3346 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4747 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:285108 (278.4 KiB)  TX bytes:5428615 (5.1 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1979 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1979 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:8579906 (8.1 MiB)  TX bytes:8579906 (8.1 MiB)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:27:cc:9e
          inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::ed16:49e3:4eeb:986a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:482 errors:0 dropped:200 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:70385 (68.7 KiB)  TX bytes:1967 (1.9 KiB)

i put this at the bottom of dhcpcd.conf:

interface eth0
static ip_address=192.168.137.7/24
static routers=192.168.137.1
static domain_name_servers=8.8.8.8 8.8.4.4 192.168.137.1

my network/interfaces:

auto lo
iface lo inet loopback
iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

resolv.conf (i can't overwrite this) :

domain mshome.net
nameserver 192.168.137.1

Other useful info:

  • dhcp is enabled in my router
  • i pinged google and it and it returns ping: unknown host google.com
  • i pinged 8.8.8.8 and it says destination host unreachable
  • From what you have posted the Pi thinks nameserver 192.168.137.1 which does not agree with what you have specified. Why? It appears you are doing something else which you aren't disclosing. Your network/interfaces is non-standard; see How do I set up networking/WiFi/Static IP and put it back to standard. WHY are you setting static? If you really MUST do this make sure you get it right (see above link). – Milliways Apr 14 '17 at 9:10
  • @Milliways i edited it again. i hope its correct this time.. but chromium is still not working :( – HITACHIINMAE Apr 14 '17 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.