1

Im doing a simple blink test on my raspberry pi zero but I am having trouble getting my gpio pins to work. I have already installed wiringpi and RPi.GPIO. My setup is simple, I connect pin #1(3.3v) to power and pin #6(ground) to ground. I have tried this setup with a battery and it seems to work just fine. Also, when I run "gpio readall" I get a table with no errors. Here is the picture of my setup:

blink project setup

I have tried the same test with a 3v battery after my test with the raspberry pi. The LED does turn on.

3v battery test

2

The power and ground pins are not GPIO.

You appear to have shorted a LED between 3V3 and ground. That will have destroyed the LED.

https://learn.sparkfun.com/tutorials/how-to-use-a-breadboard

  • No the LED still works. I have tried this with a 3v battery. The LED works fine. – km1pi_zero Apr 16 '17 at 18:03
  • The only way it would still work is if you are fortunate and fitted it back to front. It's not lit in your photo. – joan Apr 16 '17 at 19:14
  • As i mentioned before, I have tried this with a 3v battery after I posted this question. The LED lits up. My problem is not with the LED. – km1pi_zero Apr 16 '17 at 22:55
  • ...and as I pointed out to you the only way it would still work is if you connected it back to front. Your problem is you do not understand how to use a breadboard which is why I posted the link. – joan Apr 17 '17 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.