0

The aim is to run a pi in headless mode on a usb cable from a mac running os10.6(snow lep) I have loaded the latest pixel on a pi zero altered the 2 files an added an empty ssh file to the boot disc. In terminal ssh works fine, Also ifconfig discloses a usb0 inet address of 169.254.61.163. Ping this address from terminal also works fine. In addition using terminal vncserver command discloses VNC(R) Server 6.0.3 running. My problem is with VNC® Viewer 5.2.3 as I have an older mac. On connect I get the timed out message as in the title. The troubleshooting log file from VNC viewer gives VncServerLicenseManager: Setting full license key, Loading licenses from /etc/vnc/licensekey, this is repeated until time out. Any help appreciated. Roger

  • I have a guide to setting up vncserver on a headless Pi here. Maybe that'll help? – Hydraxan14 Apr 19 '17 at 23:43
1

Short of testing from another computer or tablet running a newer version of VNC viewer, I would suggest double checking the username and password, by default it is 'pi' and 'raspberry' and may be trying 'raspberrypi.local' instead of the IP.

BTW, the other thing I've noticed with a headless Pi is that the resolution in VNC is very small as there is not HDMI monitor connected, so I've Set Resolution via Raspberry Pi Configuration to DMT mode 85 1280x720 60Hz 16:9 to fit nicely on an Chromebook, which is what we use at the school for our Pi-related projects.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.