6

I just installed Raspian Jessie lite date 4-10-17. All articles state the username and password are "pi" and "rasberry". These do not work. What is the correct user and password?

  • 4
    You need to use the correct password (and user name). Computers are picky and do not tolerate spelling mistakes. – joan Apr 19 '17 at 14:33
  • 2
    I think you will find its raspberry not rasberry... – Darth Vader Apr 19 '17 at 14:52
16

The username is "pi" and the password is "raspberry", you have misspelled the word "raspberry" by missing the p.

If you still have issues, I would try re-downloading, re-formatting, and doing it once more. I think you'll be fine after correcting the password entry.

It's good practice after logging in to change the password of the user from the default.

Some users like to disable the pi account (especially if opened up to the internet) and create a new account and password to create minor security through obscurity, but it's not a replacement for following proper security practices.

Source

  • Thank you that was it. My vision must be going bad in my old age. I completely missed the spelling. – Michael Mancuso Apr 19 '17 at 15:26
1

just faced the same problem. everything written before is right, BUT : my installation had an english keyboard layout, which means, to input my "raspberry" pw i had to press "raspberrz"

  • Not tried it but this answer suggests a way of setting the keyboard from cmdline.txt so you can login locally and run raspi-config to do it properly. Alternatively I believe you can enable ssh and log in in remotely and your keyboard layout will be translated for you. – Roger Jones Jan 12 at 13:08
0

If you had a root access to your Rpi device, you can simply change the user's password, i.e. passwd pi. You can also remove the user's existing password (not recommended) by removing the 2nd field of the user account listed in /etc/shadow file (assuming shadow package is installed).

0

Your problem is 90% chance a keyboard layout problem.

Raspbian (lite) boots to tty and therefore uses a QWERTY (USA) kb layout by default.

so try rqspberry as password ;)

-1

If you are talking about root's password, its not set by default. Although whenever you write su - it asks for root password. It shouldn't ask in the first place if there isn't any.

So in order to solve this, write in terminal sudo passwd root and it will ask you twice to write password and you are good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.