I've been using a Raspberry Pi with the "Simulink Support Package" for quite some time, but suddenly the USB ports start acting out. If I keep re-attaching an USB element, it suddenly connects and works, but without touching anything, not moving it an inch, the Pi suddenly doesn't recognize the hardware anymore.


  • The ethernet still works, despite the USBs acting out
  • Either all USBs work, or they don't. Never just some of them.
  • All hardware have been tested with a laptop, where they work fine.
  • Tried reinstalling the Simulink package several times without any change in behaviour.
  • HDMI still working.

Any ideas to what could cause this fault?


I'm trying to connect an USB-keyboard and and USB microphone. Both have been working flawlessly for the past 2 weeks.

I'm using a 5V 2.5A power supply.

My USB inputs are not showed when using lsusb.

I've tried rebooting too see if the hardware would give sign of connection briefly on startup, but no result. Sat around for some minutes without touching anything, re-plugged the keyboard, which started working for a few seconds until I plugged the microphone, from which point everything stopped working again.

My first thought was the complete bus might be at fault, but the ethernet port keeps going strong.

| improve this question | | | | |
  • Try unbinding and rebinding the hub as described here and see if that makes a difference to the lsusb output (that post is WRT to an external hub, but you can do the same thing to the internal one). – goldilocks Apr 20 '17 at 12:31
  • @goldilocks Just to be clear - you wan't be to unbind 1-0:1.0 right? – Jon Dier Apr 20 '17 at 12:39
  • I believe in fact it's 1-1:1.0 ; if you look at lsusb, the hub is the first device on bus 1, parallel to the ethernet controller, and if you look in sys, it's that that has 5 (?!) ports associated with it. – goldilocks Apr 20 '17 at 12:47
  • @goldilocks Alright, can I enter the unbind/bind code anywhere in the folder(outside the functions of course), or does it have to be in a specific function? – Jon Dier Apr 20 '17 at 12:57
  • If you use the absolute path, /sys/bus/usb/drivers/hub/unbind, then you can issue the echo from anywhere. – goldilocks Apr 20 '17 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.