1

I'm in need of some explanation as my Pi is acting weird (to my limited knowledge at least)

It will only boot when i suply it with 5v/GND through the 3.3/GND GPIOs.

  • The pi boots when i connect 5v to the 3.3v pin (with only the yellow led blinking, nothing on the red, and gives the little thunder icon on its raspbian desktop)

  • It boots normally with the expected behavior on both leds (and no thunder icon) when i connect both the micro usb charger and the second power supply to the 3.3v+GND.

  • Tried two different micro usb power supplies alone, nothing, they only light the red led (no yellow led blinking). Tried 5v+gnd (from a 16x relay board) to the 5v+GND, nothing.

  • The 5v power i am connecting is from this Powered 16x Relay board (stack exchange link)

  • It's a relatively new setup (a month old) and it's been working ok till today that i disconnected the power from the relay module to reboot it.

Have i fried something?
I imagined the micro USB might be damaged, but how would that explain the fact that i need to power it through the 3.3 and not the 5v?
How can i make it boot with just its official power supply again?

  • 1
    Probably. The Foundation says "Under no circumstances should a power source be connected to the 3.3V pins". See Raspberry Pi Power Limitations – Milliways Apr 21 '17 at 2:54
  • @Milliways is the module supposed to act as a powersource? is it normal that its pins read out 5v? Check the link i provided on me asking how to connect the 16relay module. It was the only way to get it to work. – krasatos Apr 21 '17 at 7:43
  • It is not feasible to check all the hardware and the link does not point to any module. You stated "The pi boots when i connect 5v to the 3.3v pin" and "suply it with 5v/GND through the 3.3/GND". I suggest you disconnect everything to make sure your Pi works, DO NOT connect power to ANYTHING except the USB power port. If you have already asked a question, you should modify the original. I was only responding to this question. – Milliways Apr 21 '17 at 8:47
  • Thanks for your reply @Milliways, Check the 3rd bullet on my question: When i connect ONLY usb, i get just red led on and no boot – krasatos Apr 21 '17 at 8:51
  • In this case your Pi is probably dead! There are other possibilities, blown polyfuse (try in 24 hours) or SD Card problems. – Milliways Apr 21 '17 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.