1

I installed RKHunter (rootkit hunter) on Raspbian Jessie using "apt-get install". Before that I performed apt-get update and upgrade as well as autoclean.

When setting up RKHunter, the first few steps are working. But then for some reason I can't check the current values and store them as known-good values using sudo rkhunter --propupd.

I get the message Invalid SCRIPTWHITELIST configuration option: non-existent pathname: usr/bin/lwp-request

Why am I getting this and how can I fix it please ?

I followed the following guide however I didn't install from sources but with apt-get: https://www.digitalocean.com/community/tutorials/how-to-use-rkhunter-to-guard-against-rootkits-on-an-ubuntu-vps

1

Since nobody stepped up I continued searching and found a few things that I think can help answer this question for documentation's sake and future readers. Use at your own risk. If anyone has some insights or input as to the safety or logic of doing this please let us know.

Potential answer/solution: Based on the following links, it seems that it is possible and safe to comment out the offending elements out of the /etc/rkhunter.conf file.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773974 http://www.itrig.de/index.php?/archives/2182-Rkhunter-Rootkit-Hunter-und-Chrootkit-auf-Ubuntu-installieren,-aktualisieren-und-konfigurieren.html ("Troubleshooting" part).

Will test it out and report back.

  • Checking back to conclude: commented out the option regarding usr/bin/lwp-request in /etc/rkhunter.conf as explained at bugs.debian.org/cgi-bin/bugreport.cgi?bug=773974. It worked and now rkhunter executes normally. Use at your own risk. – MFJC May 8 '17 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.