0

I am using the pps-gpio dtoverlay. My /boot/config.txt has these lines:

# Expect the GPS 1PPS pin to be connected to GPIO3
dtoverlay=pps-gpio,gpiopin=3

Problem is, that the GPS Module (SkyTraq Venus) goes into a debug mode if the PPS pin is pulled high while power is applied. According to this page, GPIO3 is pulled high by default during boot. I confirmed this on my RPI3.

When I connect PPS to GPIO18, which is pulled low during boot, it works just fine. However, I'm stuck with GPIO3, since my circuit boards are already manufactured.

sudo gpio -g mode 3 down has no effect. Is there another way to disable the internal pull-up, or even enable a pull-down, while keeping the pps-gpio dtoverlay?

1

No, pins 3/5 (GPIO 2/3) have hard-wired 1k8 pull-ups to 3V3 fitted (so they can function as the I2C bus).

You can not disable these pull-ups in software.

You will have to physically unsolder the resistor.

See Raspberry Pi schematics.

  • Thanks! Would you add a link to documentation or schematic that shows the resistor, please? – rudolfbyker Apr 26 '17 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.