1

I am not able to SSH to Raspberry Pi 3 from Putty. I can ping the 192.168.137.1 IP address assigned by sharing Internet connection. Note: I do not have HDMI monitor so need to access remotely only. The problem I realized that SSH is not enabled by default in Pi3 and saw the posts which suggest to enable SSH by creating 'ssh' file inside /boot folder. I got the SD card which has pre-installed Noobs so when I open SD card it shows only /recovery folder. How to enable SSH in this case ? Please help to resolve it .

Even if i get monitor which supports HDMI, it seems i need to edit the display settings to adjust the screen resoltuion to 1920 *1080 by changing /boot/config.txt file. But i can not see boot folder in SD card. Please help to resolve this.

  • It is extremely unlikely that 192.168.137.1 is the IP address of the Pi! Your question is lacking detail (of config), but it appears you are using ICS. If this is so you cannot also ssh over the link. You can have either ICS or local access (without complex bridging). Connect the Pi to your router. – Milliways Apr 26 '17 at 22:56
2

If you can somehow get the display up and running, you can enable SSH from raspi-config. For me the 'ssh' file in /boot partition didn't work. But I'll give you a walkthrough anyway, since I saw some false info in your post.

NOTE

Try using Raspbian instead of NOOBS, since it's a bit less complicated (yes, believe me).

Enable SSH from raspi-config

These instructions assume you have working internet connection.

  1. Run sudo raspi-config
  2. Select Interfacing options
  3. Select SSH
  4. Select Enable
  5. Reboot
  6. SSH into it.

Enable SSH from /boot

These instructions assume you have working internet connection.

  1. Plug in your sd card to any computer that supports it.
  2. Find partition called boot, it's FAT32. It's not a folder, but a partition.
  3. Create an empty file called ssh, without any extensions.
  4. Insert your sd card into the RPi and wait for it to boot.
  5. SSH into it.

Link to official guide

  • Did you, by accident, try to create /boot/ssh on the root partition, instead of creatingssh on the boot position? – TheDiveO Aug 7 '17 at 17:39
0

I don't suggest to use noobs which makes a lot of thinks much more complicated.

Install Raspbian on a SD card instead. Next create a file called 'ssh' on the boot partition.

If you have a Linux box handy mount the SD card and partition mmcblk0p1. Then just execute touch ssh

If you use Windows the boot partition will be mounted as soon as you plug in the SD card. Open any editor you are familiar with on Windows and create a file called 'ssh' and save it.

That way your Raspi will enable the ssh port when booting :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.