3

Following this tutorial https://www.security-sleuth.com/sleuth-blog/2017/3/6/installing-poison-tap-for-dummies-the-most-complete-guide I am trying to install Poison Tap as part of a school project. However I got stuck at the Configuring your poison tap section of the tutorial.

The DHCP server refuses to start. Running the sudo service isc-dhcp-server start command I get the following error message:

Job for isc-dhcp-server.service failed. See 'systemctl status isc-dhcp-server.service' and 'journalctl -xn' for details.

Then I check the error message privided by systemctl status isc-dhcp-server.service

    pi@raspberrypi:~ $ systemctl status isc-dhcp-server.service
    ● isc-dhcp-server.service - LSB: DHCP server
       Loaded: loaded (/etc/init.d/isc-dhcp-server)
       Active: failed (Result: exit-code) since Sun 2017-04-30 09:29:49 UTC; 1min 10s ago
      Process: 9931 ExecStart=/etc/init.d/isc-dhcp-server start (code=exited, status=1/FAILURE)

Which isn't telling me much(except the service doesn't want to start). So I check to get even more details with sudo journalctl -xn:

pi@raspberrypi:~ $ sudo journalctl -xn
-- Logs begin at Mon 2017-04-10 11:17:01 UTC, end at Sun 2017-04-30 09:35:16 UTC
Apr 30 09:35:06 raspberrypi dhcpd[10105]:
Apr 30 09:35:06 raspberrypi dhcpd[10105]: exiting.
Apr 30 09:35:08 raspberrypi isc-dhcp-server[10097]: Starting ISC DHCP server: dh
Apr 30 09:35:08 raspberrypi isc-dhcp-server[10097]: failed!
Apr 30 09:35:08 raspberrypi systemd[1]: isc-dhcp-server.service: control process
Apr 30 09:35:08 raspberrypi sudo[10076]: pam_unix(sudo:session): session closed
Apr 30 09:35:08 raspberrypi systemd[1]: Failed to start LSB: DHCP server.
-- Subject: Unit isc-dhcp-server.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit isc-dhcp-server.service has failed.
--
-- The result is failed.
Apr 30 09:35:08 raspberrypi systemd[1]: Unit isc-dhcp-server.service entered fai
Apr 30 09:35:16 raspberrypi sudo[10113]: pi : TTY=pts/0 ; PWD=/home/pi ; USER=ro
Apr 30 09:35:16 raspberrypi sudo[10113]: pam_unix(sudo:session): session opened

And since I am trash at configuring a network I get lost in all of this.

Running ifconfig I get this output:

pi@raspberrypi:~ $ ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:136 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:11472 (11.2 KiB)  TX bytes:11472 (11.2 KiB)

usb0      Link encap:Ethernet  HWaddr 76:22:25:a8:d2:97
          inet addr:192.168.137.213  Bcast:192.168.137.255  Mask:255.255.255.0
          inet6 addr: fe80::1c81:544b:fc83:9c1b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:74409 errors:0 dropped:9 overruns:0 frame:0
          TX packets:13024 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:101146949 (96.4 MiB)  TX bytes:2038369 (1.9 MiB)

My dhcp file looks like this:

pi@raspberrypi:~ $ sudo cat /etc/dhcp/dhcpd.conf
# /etc/dhcp/dhcpd.conf

# notes below
ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
authoritative;
log-facility local7;

# describe the codes used for injecting static routes
option classless-routes code 121 = array of unsigned integer 8;
option classless-routes-win code 249 = array of unsigned integer 8;

# A netmask of 128 will work across all platforms
# A way to cover /0 is to use a short lease.
# As soon as the lease expires and client sends a
# new DHCPREQUEST, you can DHCPOFFER the other half.
subnet 0.0.0.0 netmask 128.0.0.0 {
        range 1.0.0.10 1.0.0.50;
        option broadcast-address 255.255.255.255;
        option routers 1.0.0.1;
        default-lease-time 600;
        max-lease-time 7200;
        option domain-name "local";
        option domain-name-servers 1.0.0.1;
# send the routes for both the top and bottom of the IPv4 address space
        option classless-routes 1,0, 1,0,0,1,  1,128, 1,0,0,1;
        option classless-routes-win 1,0, 1,0,0,1,  1,128, 1,0,0,1;

}

And my interfaces file looks like this:

pi@raspberrypi:~ $ cat /etc/network/interfaces
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0

auto usb0
    allow-hotplug usb0
    iface usb0 inet static
    address 1.0.0.1
    netmask 0.0.0.0

What am I missing?

  • A ******* reboot that's what was needed to make this work! – Lucian Tarna Apr 30 '17 at 11:16
1

you just have to reboot your pi, is that simple.

  • 1
    :))) well can't argue with my own answer – Lucian Tarna May 5 '17 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.