1

I am experiencing an issue and not sure where to go from here to resolve the problem.

I have purchased a Kuman 3,5" TFT screen for my Pi, installed it using the drivers and scripts from https://github.com/goodtft/LCD-show.git. So far so good, the display works! I have used the 2017-04-10-raspbian-jessie.img without using updating and upgrading.

The problem occurs after I use:

sudo apt-get update
sudo apt-get upgrade

Once rebooted the Display just turns white, does not show the startup output any longer and does not display the desktop. Looking at the Xorg.0.log file seems to indicate that the Display can no longer be found. I have double checked that all configuration settings made to enable to display are still there. Even tried to re-run the installation scripts, however this does not solve the issue.

[     9.406] (EE) open /dev/fb1: No such file or directory
[     9.406] (EE) No devices detected.
[     9.406] (EE)
Fatal server error:
[     9.406] (EE) no screens found(EE)

Quickly looking at the file/directory seems to confirm this:

ls -lah /dev/fb1
ls: cannot access /dev/fb1: No such file or directory

When looking at dmesg output I did notice:

[    3.762397] spi_master spi0: spi_device register error /soc/spi@7e204000/tft35a-ts@1
[    3.762410] spi_master spi0: Failed to create SPI device for /soc/spi@7e204000/tft35a-ts@1

This I have not seen before.

It would be highly appreciated if anyone could push me in the right direction to solve this problem. I have tried googling, but cannot find anything that helps or I can understand. :(

Cheers,

Innidael

=============== Update 2-4-2017

After some further Googling I stumbled upon the Kuman website with the Display in question (hxxp://kumantech.com/kuman-35-inch-tft-lcd-display-480x320-rgb-pixels-touch-screen-monitor-for-raspberry-pi-3-2-model-b-b-a-a-module-spi-interface-with-touch-pen-sc06_p0014.html). They seem to have a support section for the display with a link to the "latest" drivers. IT is a link to a mega.nz file share, https://mega.nz/#F!HUFQFDwL!fhM7RPrhbMJLsZ7ISLEr0A!2JNQAaII. These drivers however also do not fix the issue.

I contacted their support to see if they could either supply the drivers for the new kernels or give some indication on how to get them to work. their response consisted of a single line: "Sorry, we do not have that.". I am therefore unsure if any additional help to solve this issue can be expected from their side.

I guess it would be better to return the display under warranty and try find one which would be supported (adafruit maybe?).

Ps. Sorry about the links being mangled it seems i do not have enough reputation to post more than 2 links :)

  • Have you tried using mknod to manually create the /dev/fb1 device? – Mike Harris May 26 '17 at 13:12
1


unfortunatey the re-install you mentioned does not work since the kernel version seems not to be in the repository any more. Since I noticed the issue afterwards the upgrade, I was in the same situation as Innidael. Nevertheless I found the necessary packages still being stored in the apt cache /var/cache/apt/archives/. Therefore I was able to install both packages manually by using

dpkg -i /var/cache/apt/archives/raspberrypi-bootloader_1.20170405-1_armhf.deb /var/cache/apt/archives/raspberrypi-kernel_1.20170405-1_armhf.deb

Beware, this is only possible if you don't execute an "apt-get clean". Maybe it is a good idea to store both packages in a save place and also setting them to hold.

1

Same for me (I'm using the same display). Solved it by re-installing and setting the packages raspberrypi-kernel and raspberrypi-bootloader to "hold":

sudo apt-mark hold raspberrypi-kernel raspberrypi-bootloader

before upgrading. It might also work to "revert" to the old kernel/bootloader (instead of reinstalling) by doing:

sudo apt-get install raspberrypi-kernel=1.2070405-1 raspberrypi-bootloader=1.2070405-1

but I have not tested this myself as I'm currently just setting up my system. Of course this is not a permanent solution as it will block all future kernel updates, so a real solution would be welcome.

1

This Config need to be use with ssh remote Please Pay attentions xD First of all install normal libray LCD-SHOW-XX-XX-XX.TAR.GZ extract and find lcd35-show and then run => ./lcd35-show

next Install kedei library with LCD35 and then chose LCD-hdmi in kedei

go to website http://kedei.net/raspberry/raspberry.html download LCD_show_v6_x_X into your rapberry pi

and extract file and run ./LCD35... (inside that file you extract )
you will see little messy in the screen in your module LCD 3.5 inch and than you run inside the same directory ./LCD-HDMI (waiting until reboot it self) Finally you will see it run your module LCD 3.5 inch

if you want to config speed that LCD 3.5 inch

-> config Frequency and frame in /boot/config.txt

in the last line ..., speed = 10000000, fps=25

it's mean frequencey 10 Mhz and frame 25 per second can config speed LCD Hope it can help , :D

protected by Darth Vader Jun 15 '18 at 12:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.