1

I have a small problem with my headless raspbian torrentbox, when I reboot transmission-daemon is running:

simone@raspberrypi:~ $ sudo service transmission-daemon status
[sudo] password for simone: 
● transmission-daemon.service - Transmission BitTorrent Daemon
   Loaded: loaded (/lib/systemd/system/transmission-daemon.service; enabled)
   Active: active (running) since Mon 2017-05-01 10:49:47 EDT; 3min 13s ago
 Main PID: 526 (transmission-da)
   Status: "Uploading 2318.44 KBps, Downloading 39.32 KBps."
   CGroup: /system.slice/transmission-daemon.service
           └─526 /usr/bin/transmission-daemon -f --log-error

May 01 10:49:45 raspberrypi systemd[1]: Starting Transmission BitTorrent Daemon...
May 01 10:49:47 raspberrypi systemd[1]: Started Transmission BitTorrent Daemon.
May 01 10:49:49 raspberrypi transmission-daemon[526]: [2017-05-01 10:49:49.514 EDT] UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
May 01 10:49:49 raspberrypi transmission-daemon[526]: [2017-05-01 10:49:49.515 EDT] UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)

but transmission-remote is not working:

[2017-05-01 10:54:15.719 EDT] transmission-remote:  (http://localhost:9091/transmission/rpc/) Couldn't connect to server

When I restart transmission-daemon transmission-remote starts working again, do you have any idea why?

Thank you

1 Answer 1

-1

Try to enable "Wait for Network at Boot" at sudo raspi-config, this works for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.