3

I spent nights trying to configure WiFi. I have edimax 7811un, RP2 with Jessie.

What is this "unassociated" issue?

Please don't post solutions older than 2016 because the newer versions of Raspbian are different. I have been through them all.

My router follows wpa-psk

pi@raspberrypi:~ $ iwconfig
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated
          Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

My wpa_supplicant life

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="myssid"
        #psk="something"
        # psk=d1767cc32480efnffj81499bf877752c1550a4cd42f740d66a990accbf744364

        psk=45ed2dc498fe05646f086d66b845a4b739c4023de1549ccc6e4a8ed6c496b6b7
        key_mgmt=WPA-PSK

}

My interfaces file

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

#The lan network interface
iface eth0 inet manual


allow-hotplug wlan0
iface wlan0 inet manual
   wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Consider this as well

pi@raspberrypi:~ $ dmesg | grep wlan0
[    7.356938] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

The unassociated problem was solved thanks to a previous post I missed.

Now

pi@raspberrypi:~ $ iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:"bharatbusan"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.417 GHz  Access Point: 80:A1:D7:15:E9:88
          Bit Rate:72.2 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=98/100  Signal level=56/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

and

sudo route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    202    0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    303    0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     202    0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     303    0        0 wlan0

And still when I ping to anything I get destination host unreachable. I read somewhere that maybe my gateway settings are wrong.

  • i also found this: the new default network manager Wicd does not recognise this configuration. So use the wpagui manager instead, and just disable or remove wicd – Dev_Man May 2 '17 at 9:55
  • "Please dont post solutions older than 2016" -> Note while the duplicate question is from 2015, the duplicate answer has been kept updated (edited less than a week ago). – goldilocks May 2 '17 at 12:53
  • @goldilocks thank you could you pls see my second edit as well I am still stuck with an error – Dev_Man May 2 '17 at 13:14
  • @goldilocks please feel free to take a look at this [latest question of mine if possible.] (raspberrypi.stackexchange.com/questions/66617/…) – Dev_Man May 2 '17 at 19:59
0

I added the line auto wlan0 to my interfaces file just above allow hot-plug wlan0 line and rebooted. It worked perfectly. The other question I added in my comments, I found solution for that as well thanks to the forum.

| improve this answer | |
0

Just to clarify the solution. This will work if you add these lines to the /etc/network/interfaces file:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
  wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.