0

I have a Raspberry Pi 3 Model B and was using the inbuilt Wifi interface with no problems. I was using it as a web server which I'd SSH into. However, after being unable to SSH into it, I've seen that it's now showing me the message "No wireless interfaces found" in the Raspbian UI taskbar.

What could cause this to stop working so suddenly without (to my knowledge) any messing around with config settings? How do I fix this? The Pi has just been sitting on my desk so I can't imagine it's physical damage.

The output of ifconfig:

eth0      Link encap:Ethernet  HWaddr b8:27:eb:4e:f2:ad  
          inet6 addr: fe80::b93d:28fd:d73e:d13f/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr b8:27:eb:1b:a7:f8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:1 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60 (60.0 B)  TX bytes:0 (0.0 B)

Although wlan0 is displayed in this output, the Raspbian UI is not reflecting this.

I should also note, because this is often an issue, that my power supply should be sufficient as I'm using the official 2.5A PSU.

7
  • You need to explain the context of 'now decided to show me the message "No wireless interfaces found"', since your ifconfig output contradicts this. It shows the wifi interface (wlan0) as UP.
    – goldilocks
    May 3, 2017 at 10:52
  • True, it does contradict this, but when I click the wireless interfaces button in the UI (I'm using Raspbian) it simply says 'No wireless interfaces found' as opposed to listing any access points.
    – petehallw
    May 3, 2017 at 11:01
  • Okay. Then you should describe that. Not everyone uses that interface, and I suspect that message is passed on verbatim from something else, so as currently written, it is left up to the reader to guess what you are talking about (e.g., since you ssh in, it might be assumed you are using it headless sans GUI). You might also want to indicate that you are aware the wifi is shown as up w/ ifconfig.
    – goldilocks
    May 3, 2017 at 11:04
  • Hmm, I have had a similar problem and moving the Pi 3, the wifi reconnected. Dead spot I thought. It worked for a while until I plugged in a USB stick and it quit again. I wiggled the USB connectors and it connected again. Yesterday when I powered it on, no wifi connection. I have ordered a new PI 3.
    – bstipe
    May 23, 2017 at 21:42
  • @bstipe Interesting, I have recently mounted a USB stick to back up some files. I'll see if plugging/removing this works.
    – petehallw
    May 23, 2017 at 21:57

4 Answers 4

1

Have you tried setting it up before you even boot it up? I was trying to set up a pi zero w but didn't have the right adapters. So I found a way to set it up in Windows. This is the easiest way I found to do it and have done several times now.

Instructions from the site.

Insert your SD card with Raspbian into it into your computer and open the SD card from your file explorer - the drive will be labelled boot.

pic1

Within the boot directory, Right-Click > New > Text Document and rename the document to wpa_supplicant.conf - Make sure that you change the file extention from .txt to .conf - You will be prompted to confirm the extension change.

pic2

With the empty file created, Right-Click on it an select open. You may be prompted to select a program you'd like to open the file with - just choose Notepad.

This is where we enter our WiFi details. Enter the following text into the file, replacing the placeholder text with your own details.

network={ ssid="SSID" psk="password" key_mgmt=WPA-PSK }

SSID is the name of your WiFi network, and psk is your WiFi password.

pic3 Enable SSH

By default, the current version of Raspbian has SSH disabled. We're going to enable it here.

Create an empty file in the boot directory called ssh

Make sure that the file has no file extension, i.e. remove the .txt if you created the file by selecting New > Text File.

pic4

Connect

Your Pi is now ready for startup. Eject the SD card from your computer and insert it into your Pi. Power up your Pi (we recommend an official power supply) and wait a few moments for the initial boot to complete. On your computer, open up PuTTY.

We know that the default host name (the name of the machine) for a fresh Raspbian install is raspberrypi, so in the Host Name (or IP address) field enter raspberrypi. This searches for machines on that name on the local network. Once a connection is established, you'll be prompted by PuTTY to accept the connection to the new machine. You should see a black terminal prompting for a login. Enter the default username: pi and the default password: raspberry

If you get an error saying the host does not exist, try the troubleshooting steps.

pic5

3
  • It would be a good idea to include relevant information from the link in your answer.
    – Darth Vader
    Jan 11, 2018 at 12:14
  • That's a much better answer now. Link only answers are discouraged because if the link breaks, the answer isn't of any use. I should also mention since you're new to the site it would be a good idea to take the Tour to find out how things work around here.
    – Darth Vader
    Jan 11, 2018 at 13:04
  • I should have guessed that's why. Thank you. I will.
    – Proton
    Jan 11, 2018 at 13:11
0

I was having the same issue and found out for me at least, it was a permissions issue. I logged in with an account I created with basic permissions but as soon as I logged in under my "pi" account, the wireless connections appeared.

0

This is a bug... I don't know how to solve this but if you cannot connect to a wifi network then try this from terminal:

sudo apt-get install wpa_supplicant
sudo nano /etc/wpa_supplicant.conf

now fill the file with credentials e.g.

network={
    ssid="TestAP"
    psk="password"
}

now run command(assuming wlan1 is your interface):

sudo wpa_supplicant -B -iwlan1 -c/etc/wpa_supplicant.conf -Dwext
sudo dhclient wlan1

this will help to connect to a wifi network if you cannot mange yourself from network manager on taskbar.

cheers!

0

I tried a Raspberry Pi 2 model B with a realtek usb dongle to connect to the wireless network, with the current version of raspbian I had the error of "No wireless interface found" I found another rpi with the same usb dongle and it worked correctly, when validating the raspbian version was Stretch, I downloaded the image, installed it in the microsd and it worked correctly.

You can download it from the following URL:

https://downloads.raspberrypi.org/raspbian/images/raspbian-2019-04-09/

1
  • Unfortunately we are English only, but google translate works quite well in this case. Please take the tour to understand better how the site works.
    – goldilocks
    Jan 7 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.