1

I have the following set-up. A RaspberryPi3 and on top of it I placed the Adafruit DC motor hat.

http://i.imgur.com/aZzkP7p.jpg

I enabled the I2C from Raspi-Config, installed python-smbus and i2c tools, added the i2c-bcm2708 i2c-dev in /etc/modules.

When I run in the command line sudo i2cdetect -y 1 I see only dashes, so no adress is in use. I tried running the command with the Sensehat on and I saw some addresses being used.

How can I fix the issue?Thanks in advance.

  • What issue? You need to explain what you have physically connected to the Pi, what i2c_detect shows, and what you expect it to show. You also need to tell us basic things like the results of uname -a and cat /etc/os-release. A photo may also be useful. – joan May 3 '17 at 8:04
  • I am out of edits, but the picture link is in the text. It just needs a little reformatting to make it show correctly. – SDsolar May 4 '17 at 5:32
  • You are saying that it does detect something when the hat is turned on? – Dr_Bunsen May 4 '17 at 13:54
  • Yes. I was following this guide, link and when I ran sudo i2cdetect -y 1 i would get no addresses being used. Then I soldered the pins and now I have two addresses are in use 0x60 and 0x70. – Filip Rus May 7 '17 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.