3

I have a new Camera Module V2 that I tried to hook up with a new Raspberry Pi Zero W with this adapter cable.

When I call raspistill -o test.jpg I get

mmal: Cannot read camera info, keeping the defaults for OV5647    
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly

I actived the camera and tried all the things from the troubleshooting section from this website: https://www.raspberrypi.org/documentation/raspbian/applications/camera.md

vcgencmd get_camera

shows

supported=1 detected=0

When I try the camera module with my Raspi 3 and the original cable it works fine.
Is there any way to check if the problem is the cable or the Pi zero?
I have a breadboard and a few leds, cables and things like that, in case I could use this to build something like an amperemeter.

  • There are very similar questions which were solved by running sudo apt-get update and sudo apt-get upgrade. Did you run those while you were working through the troubleshooting page? It would also be tremendously helpful if you could edit the question to expand a little on what you mean by 'adapter cable' - do you have a spec sheet or link to a sales page? – goobering May 5 '17 at 12:21
  • I added the amazon page for the cable. update, upgrade, rpi-update, I did them all. – Felix Auer May 5 '17 at 12:42
  • 1
    Stupid question time: Is the cable the right way round? – goobering May 5 '17 at 12:51
  • Yes the cable is the right way – Felix Auer May 5 '17 at 12:55
  • If the system's up to date, you've enabled the camera, the camera's plugged in the right way round and you're using the right command then I think I'm about out of suggestions. I think the only remaining candidates are insufficient power supply, bad cable, or bad camera connector. The first two are easy enough to check (sub in bigger (circa 2A) power supply, multimeter probe cable to check continuity), but for the Pi camera connector you'd need to test it with a known-good cable and camera, i.e. get another Pi Zero fully working with the camera, then swap the non-working Pi in. – goobering May 5 '17 at 13:02
0

Everything you have mentioned here leads to either the cable or the connector on the Pi-Zero W being bad.

  • The Camera is good because it works with the Pi-3 and the other cable.
  • The settings to enable the camera look right on the config.

At this point I would try getting a new adapter cable, maybe even from a different manufacturer if possible. If that doesn't solve the problem, you are most likely looking at a bad CSI connector on the board, which is best solved with another board.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.