0

I'm using the Raspbian image 2017-04-10-raspbian-jessie.img (not Lite) and when I rebooted it today a dialog box came up and said that the system had been upgraded to the latest version, some config files had been overwritten but backed up etc.

But since this Raspberry Pi will be running unattended I don't want automatic updates (also because it actually broke the system and keyboard/mouse no longer works, probably because on bootup it says it failed to start some kernel modules).

How do I disable these automatic updates which obviously is enabled by default?

  • 2
    Raspbian does NOT automatically update. If this is the 1st time you have run GUI since an update which changed the settings you will get this prompt. But then if you are running unattended you probably won't be using GUI! – Milliways May 7 '17 at 8:59
  • I do use GUI but you might it right - it could be the first time I ran the GUI after doing an update... We'll let the case rest there. – TheStoryCoder May 7 '17 at 19:09
1

You might have unattended-upgrades installed, since Raspbian doesn't update automatically by default.

To remove it - just use apt -

sudo apt remove unattended-upgrades

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.