0

I've got Sweex Nano Wifi Adaptor and I haven't got to use it yet. I'm using Raspian Wheezy and am definitely not a whiz with linux.

I downloaded these drivers: firmware-realtek,wireless-tools and installed them (using dpkg -i) but still I couldn't see the adaptor in wpagui.

Found these two posts here:1,2 and tried the suggestions but had no luck so far.

/etc/network/interfaces was already setup as advised in this post and /etc/wpa_supplicant/wpa_supplicant.conf was also configured, but I did not carry on with futher steps.

When I use lsusb I only see Sweex but no other details. Any hints on how I can use the Sweex wifi adaptor on my pi ?

1

Raspbian seems to have the basic drivers for wifi devices. I suggest you connect to internet using ethernet and downloading "wicd". Once this is done, poweroff your pi and then remove the ethernet cable and attach the wifi adaptor that you have. Poweron and once you log in, go into internet in the main menu and click on wicd.

If it detects your wlan0 then you do not need the drivers and all you have to do is connect to the internet.

Note: This process can be avoided if wap_gui shows wlan0

If this succeeds then I'll give you the steps to configuring your wifi, otherwise, will have to try something else.

  • I don't have an ethernet cable, currently am adding new files to the pi with an USB stick :) Will try wicd. Unfortunately wpa_gui does not show wlan0 (the list is empty) and lsusb only show Sweex, but no other details. I'll give wicd a shot and let u know how it went. Thanks (+1) – George Profenza Mar 30 '13 at 14:27
  • I've downloaded and unzipped wicd but I ran into some python errors trying to set it up. Haven't found an easy way to install wicd while offline. Any hints ? – George Profenza Mar 30 '13 at 18:20
  • started with the default download and ran into a python error because there is no gobject library. went for the wicd debian installer and also grabbed the wicd-daemon and wicd-gtk .deb files. Installed those, then ran into the same arror. Finally downloaded pygobject 3.0.0 but when I tried sudo ./configure I got a command not found error which makes no sense to me. Any tips on how I can move forward. I did not expecting this to take so long :( – George Profenza Mar 30 '13 at 18:48
  • Okay... Firstly you need to update your pi... You need to follow these steps...1. Connect to internet through ethernet. This is mandatory. You need to do this to update your pi. try using a friend's internet. Then type the following commands in terminal apt-get update and apt-get upgrade...I've done some research and it turns out, if wap_gui does not detect wlan0 when you connect your adapter, wicd may not as well. But still to ensure that it is not so...Install "wicd" using apt-get install wicd...then check if it lists wlan0 in interfaces and tell me. – Ananth Apr 1 '13 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.