6

My Pi is connected to my TVs usb port which works great and I use the TV remote to control it - which I also enjoy.

The problem is whenever I turn on my TV, the pi changes the TV input source even though I don't want it to.

Is there a way to keep hcmi-cec enabled without it automatically controlling the source on the TV?

thanks

3
  • Can you explain further? You're powering your pi through the TV's usb port? Which source is being changed - the video? – phalt Mar 30 '13 at 10:22
  • The Pi is physically changing the source on my tv to display the output of the Pi on my tv. – user6685 Mar 31 '13 at 1:22
  • Did you find a solution for this? (Prevent XBMC from starting your TV via HDMI on (re-)start) – Stefan May 7 '13 at 9:43
6

You can try adding hdmi_ignore_cec_init=1 config option to your /boot/config.txt. It should, in theory, disable sending initial active source message by RaspberryPi which is probably responsible for changing input source to HDMI in your case.

2
  • thanks Krzysztof that worked great for the Pi itself, now xbmc seems to be changing the hdmi source as well. is there a way to turn it off from within xbmc? – user6685 Mar 31 '13 at 1:35
  • I don't use XBMC so I can't test it but there should be an option in XBMC settings to disable this. It should be called Power on TV when starting XBMC or similar. – Krzysztof Adamski Apr 1 '13 at 9:13
6

In addition to @Krzystof 's excellent answer, I would quote what I read in this post:

Include the hdmi_ignore_cec_init=1 switch in /boot/config.txt.

Then in Settings>System>Input devices>Peripherals>CEC turn off the option: "Make XBMC the active source at start".

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.