I'm new to this. I followed this documentation to set up as a stand alone access point network.


However, after that, I am unable to use my Raspberry Pi and connect to the internet. I wanted to download an IDE on my Raspberry Pi.

How do I enable back my wifi? I know that due to setting up of access point, it disabled my wifi capability.

  • Was WiFil working before hand? If so, it's likely that the /etc/wpa_supplicant/wpa_supplicant.conf got deleted or changed. May 9, 2017 at 15:17
  • Yes it was working beforehand. Ahh, so the only way to fix it is by re-flashing the Raspian OS onto the microsd?
    – Marcus
    May 9, 2017 at 15:37
  • Not at all. You can sudo nano /etc/wpa_supplicant/wpa_supplicant.conf and add the appropriate stuff in there. I don't recall off the top of my head what goes there but you can google "wpa_supplicant.conf" and get what you need. May 9, 2017 at 17:30
  • Oh that's great! I will try it tomorrow and let you know if it works! thanks
    – Marcus
    May 10, 2017 at 4:28
  • 1
    @CharlieHorse I managed to solve the problem! Thanks alot man!
    – Marcus
    May 11, 2017 at 6:18

1 Answer 1


Following CharlieHorse's comment, I did the following:

Turns out, it was because i changed the wlan0 codes while setting it up as an access point. This is what i did. I revert the settings back to default on my

sudo nano /etc/network/interfaces using the link below.


Then, in sudo nano /etc/dhcpcd.conf, i removed:

denyinterfaces wlan0

I reboot, and my wifi is back to normal! :)

  • 1
    If you followed that ancient link your "restored" your Pi to obsolete settings! These do work, but disable some of the newer fearures. See How do I set up networking/WiFi/Static IP In future whenever changing config files save a copy of the original.
    – Milliways
    May 11, 2017 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.