2

I'm trying to set up a pair of Raspberry Pi 3 to work with the NRF905 transciever following this guide. I'm using the same raspbian version that was used in the guide (Raspbian Jessie Lite 2016-11-25) Everything works fine when I do the apt-get update and dist-upgrade. But when I install the kernel with exported symbols, change the /boot/config.txt and then reboot, the Raspberry Pi doesn't boot anymore, the only thing I get it's a Rainbow screen.

I installed the kernel with:

sudo apt-get install linux-image-4.4.0-1-rpi2 linux-image-rpi2-rpfv linux-
headers-rpi2-rpfv 

If I pull out the SD card from the Raspberry Pi and edit the config.txt commenting the lines I just added, the Raspberry boots normally, so I'm guessing there must be something wrong with those lines in the config.txt:

# use the rpfv kernel
kernel=vmlinuz-4.4.0-1-rpi2
initrd=initrd.img-4.4.0-1-rpi2 followkernel

I used gparted to format the SD card, and etcher to burn the Jessie image to the SD Card.

Does anyone know what's the issue here?

2

There are a couple of problems.

  1. The dtbs in the current raspberry pi foundation firmware package are incompatible with that kernel.
  2. The cmdline.txt on the current foundation images uses root=PARTUUID= . Unfortunately this doesn't work with initrds created by jessie's initramfs-tools.

For the first problem right now you have a couple of options.

  1. Use the newly uploaded "linux-image-4.9.0-2-rpi2" kernel package with the raspberry pi foundation firmware package.
  2. Use the "raspberrypi-bootloader-nokernel" package from the "firmware" section of the raspbian repository.

For the second problem I recommend using a traditional device name (e.g. "mmcblk0p2") in cmdline.txt for now.

0

I have exactly the same problem and I've tinkered around without success, either with raspberrypi-ua-netinst (github) or plain latest raspbian updated. I've decided to follow to the letter the article, and downloaded http://downloads.raspberrypi.org/raspbian_lite/images/raspbian_lite-2016-11-29/, to which i didn't apply ANY update, just straight:

apt-get install linux-image-4.4.0-1-rpi linux-image-rpi-rpfv linux-headers-rpi-rpfv

After that the only modifications in /boot/config.txt are:

kernel=vmlinuz-4.4.0-1-rpi
initramfs initrd.img-4.4.0-1-rpi followkernel
dtparam=spi=on

Mind that i have a RPi1, identify your board here https://www.element14.com/community/community/raspberry-pi/blog/2016/11/21/how-to-identify-which-model-of-the-raspberry-pi-you-have ; for RPi2 you have to use the correct packages (as in the article).

Also 2016-11-29 hosts 2016-11-25 release for some reason.

Didn't wire yet the NRF905.

Also pay attention to NOT using initramfs=initrd.img-4.4.0-1-rpi but initramfs initrd.img-4.4.0-1-rpi just as above.

If you have an update on latest raspbian, would help a lot, don't want to blindly dist-upgrade/update the system if the wiring with NRF905 will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.