1

I apologize for having to create another thread about this, but after about three hours of googling, none of the numerous threads about Wi-Fi issues seems to quite match up with my setup or symptoms.

Here's what's happening: I recently wiped and reinstalled NOOBs onto my Raspberry Pi 2 to take advantage of multiboot capabilities. Mostly I want to use Raspbian. I've got a TrendNet USB Wi-Fi dongle attached, and the other OS's (LibreElec) can use it just fine - it sees networks, connects to them, and transfers data like normal.

However, when I log into Raspbian, when I click on the Wi-Fi panel, it says "no wireless interface detected". Right clicking and trying to open network preferences gives me an error about permissions. I don't know the bash command to open up that particular panel, otherwise I'd try sudo-ing that.

The driver and firmware appear to be in place. I tried messing with various conf files with no luck. (I've since restored them to their defaults). I tried ifdown wlan0 and wlan0 ifup but I get a DHCP error, (no response after some time).

The most promising thing happened when I hooked it up to Ethernet, downloaded wicd-curses, and booted that up. Up popped an accurate list of available Wi-Fi networks. But it won't connect to the only one I have a password to. I'm quite sure I'm entering the correct password, and I've selected the correct encryption (WPA 1/2 passphrase) but the log file says bad_pass.

Any ideas what I should try next?

1

I was able to solve this by wiping and reinstalling raspbian. Which kind of sucks, but apparently if anything goes wrong during the installation of the OS (which it can, invisibly and for no apparent cause), the wifi support can easily and seriously break. Reinstalling made everything work with zero customizations etc.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.