On boot my Pi shows the standard Raspbian desktop, but then it switches to tty1 and I have to use Ctrl+Alt+F7 to get back to the desktop.

How do I fix this?


2 Answers 2


I've experienced the same problem on 2 separate, new installs over several weeks. Xserver starts up with Pixel, but then I'm taken back to TTY1. I have to Ctrl-Alt-F7 to get back to it. To reproduce, take new install of Raspbian Jesse + Pixel, then do "sudo apt-cache update && sudo apt-get upgrade". Reboot.

Have you installed RetroPie by any chance? I've compiled and installed retropie from the git repo on both installs. It has its own boot options just like raspi-config, and I've considered that this behavior might be related.

  • I installed retro pie haven't tried removing it yet. It also started around the time I added a python script to rc. local but it persist even if I remove it
    – Talon06
    May 14, 2017 at 0:28

I ran the following commands and it solved the issue.

sudo rm -R /home/pi/RetroPie
sudo rm -R /home/pi/RetroPie-Setup
sudo rm -R /opt/retropie
sudo rm -R /home/pi/.emulationstation
sudo rm -R /usr/bin/emulationstation
sudo rm -R /etc/emulationstation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.