1

I am using Raspberry pi 3 as media center with OSMC on it, it was working fine with 5.2V 2A power supply for about 3 months.

But now LAN and USB ports are not working, green LED is also not blinking on boot, but I am getting output on HDMI (though it takes more time to boot). The display on my TV shows low power symbol but I think 2A supply should be sufficient for pi without any peripherals connected. I have disconnected everything form the board (only power supply and SD card connected) but still same results.

I checked voltage output on GPIO pins and I am getting ~5.1 V and 3.24 V on pin number 2 and 1 respectively. I also tested voltage at PP7 , PP35 and PP8 all seems fine. PolyFuse also seems good.

So far I have tried latest version of OSMC, Raspbian (without NOOBS) on SandDisk ultra 16GB class 10 Sdcard, and tested these power adapters ( 5.2V 2A , 5.1V 1.5A ) .

Please let me know what can I do to narrow down the issue.

  • I have also tried official raspberry pi power supply but no improvement so far.I have observed that PP10 is 1.74 V, That means its showing 'brown out', how should I identify if its faulty regulator or any thing else? – Deep Sheth May 17 '17 at 13:27
1

"The display on my TV shows low power symbol" this has NOTHING to do with the (alleged) current rating of the power supply.

The Voltage is too low and/or the cables are inadequate. This may be a transient, so it may not show on a meter. See Raspberry Pi Power Limitations

This may (but most likely not) have anything to do with USB

  • "This may be a transient" So will it help if I monitor voltage at different test points on oscilloscope? "this has NOTHING to do with the (alleged) current rating of the power supply." currently pi is taking around 300mA when in idle condition, but still shows low power warning, if it requires extra ampere I guess my 2A power supply is capable enough to deliver at least 1A load. – Deep Sheth May 12 '17 at 12:48
  • This has happened to me and sometimes I have found that simply changing out the power cable can fix the problem. Upvote. – SDsolar May 12 '17 at 17:08
  • I tried to observe voltage over oscilloscope and got 5.3 V on gpio pin with Vpp = 160mV and 3.36 V with Vpp = 80mV , similar are the results on other pin PP7 and PP35. I think power supply must not be an issue, but I will still try different cables and other supplies. – Deep Sheth May 13 '17 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.