3

I got an error while trying to install phpmyadmin on my Raspberry Pi 3, the error message is:

dpkg was interrupted, you must manually run 'sudo dpkg --configure -a'

I think it's a problem related to the /var/lib folder, something went wrong and files got corrupted.

After running the command sudo dpkg -- etc... it seems everything is fine but when I try to install the package of phpmyadmin again, another error message appeared:

Error bus

1 Answer 1

5

Remove all the files inside /var/lib/dpkg/updates directory with the following commands:

cd /var/lib/dpkg/updates
sudo rm *

And then run this command to get the newer ones:

sudo apt-get update
2
  • 3
    Did you mean sudo apt-get update?
    – pim
    Aug 31, 2017 at 6:05
  • After a long run I found this answer. You saved my time and effort boss. I have been encountering this problem in my Raspberry Pi OS frequently !
    – Shamim
    Aug 19, 2020 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.