1

Been trying for hours to figure this out. What I did:

  • installed raspbian on the sd card
  • enabled ssh from sudo raspi-config
  • connected ethernet cable router-pi
  • grabbed pi's eth0 MAC address
  • add said MAC to the static DHCP table on the router (chose 192.168.8.12; pooling starts at 192.168.13.1; router ip: 192.168.15.15)
  • restarted everything

Now the issue: can't ssh into the pi; I tried from the pi (based on tons of searches):

  • ping 8.8.8.8 (google) -> runs indefinitely (not even fails).
  • ping google.com -> unknown host
  • ping 192.168.15.15 (router) -> same as ^
  • ssh localhost -> accept fingerprint; works
  • cable is fine
  • logging onto the router, pi doesn't show up as connected but the other devices do

ifconfig: ... eth0 ... state UP ... inet 192.168.8.12

route -n:

Destination    Gateway        Genmask         Flags Metric Ref Use Iface
0.0.0.0        192.168.15.15  0.0.0.0         UG    202    0   0   eth0
192.168.15.15  0.0.0.0        255.255.255.255 UH    202    0   0   eth0
192.168.8.0    0.0.0.0        255.255.255.0   U     202    0   0   eth0

Now I can't say I 100% understand how these work but am completely lost; can anyone spot the issue?

What can I try?

  • 2
    Why do people who "can't … " 100% understand how these work" try to manually set values? Why set a reserved address? Do you set for other devices on your network? The problem is you have apparently set an address outside the range in use on your network. – Milliways May 15 '17 at 0:03
  • @Milliways How about instead of ranting provide a solution (i.e. answer) with an explanation? Most people like myself only have some guides to follow and no time to read books on Networks. If this is some rookie mistake, all the good, one and all future readers can learn from it. – Dimebag May 15 '17 at 7:25
  • 1
    Unless you post a complete description of your (unusual) network NO ONE can give you an answer. I would recommend you forget about allocating static or reserved IP addresses and it should work out of the box. The Pi is DESIGNED to just work, and it DOES unless people fiddle with the settings. All my Pi use the default network settings. – Milliways May 15 '17 at 7:30
  • The reason was so I can SSH into it at the same IP all the time. Nevertheless, solved it myself based on your hint. Cheers – Dimebag May 15 '17 at 8:23
  • Just SSH to it by name. You'll never care about the IP address again. – CharlieHorse May 15 '17 at 15:45
0

Rookie mistake but it has to do with DHCP pooling; answer based on @Milliways' comment.

The problem was that DHCP pooling was set to start with 192.168.15.1 on a router with IP 192.168.15.15. This meant that whatever IP a connecting device might be assigned/have in the network must be in the range 192.168.15.* while the static IP I set up for the Pi was 192.168.8.12 which is outside that range (for some reason I thought any 192.168.*.* was fine). So changing the IP assigned to the Pi to 192.168.15.50 worked.

tl;dr Static IP assigned to Pi must be within router's DHCP pooling values. For 192.168.15.1 to 192.168.15.255: 192.168.15.50 = good; 192.168.20.1 = bad

Note: My router is a Zyxel NBG-419N

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.